zoukankan      html  css  js  c++  java
  • 1008 Elevator

    The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

    For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

    Output Specification:

    For each test case, print the total time on a single line.

    Sample Input:

    3 2 3 1
    
     

    Sample Output:

    41

    题意:

    一个电梯走完所要求的楼层,上一层需要6分钟,下一层需要4分钟,每到达一层需要等5分钟。

    Code:

    #include<iostream>
    #include<vector>
    
    using namespace std;
    
    int main() {
        int n, t;
        cin >> n;
    
        vector<int> req;
    
        int total = 0, pre = 0;
        for (int i = 0; i < n; ++i) {
            cin >> t;
            if (t > pre) {
                total += (t - pre) * 6 + 5;
                pre = t;
            } else {
                total += (pre - t) * 4 + 5;
                pre = t;
            }
        }
    
        cout << total;
    
        return 0;
    }
    

      

    永远渴望,大智若愚(stay hungry, stay foolish)
  • 相关阅读:
    获取目录下所有文件名
    毕业论文endnote使用
    CoinChange
    sublime3个人配置
    2015-12-31
    2015-12-09
    #define DEBUG用法
    fiddler介绍
    app测试模块
    android SDK_安装配置_使用
  • 原文地址:https://www.cnblogs.com/h-hkai/p/12580392.html
Copyright © 2011-2022 走看看