zoukankan      html  css  js  c++  java
  • 1011 World Cup Betting

    With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

    Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

    For example, 3 games' odds are given as the following:

     W    T    L
    1.1  2.5  1.7
    1.2  3.1  1.6
    4.1  1.2  1.1
    
     

    To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be ( yuans (accurate up to 2 decimal places).

    Input Specification:

    Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to WT and L.

    Output Specification:

    For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

    Sample Input:

    1.1 2.5 1.7
    1.2 3.1 1.6
    4.1 1.2 1.1
    
     

    Sample Output:

    T T W 39.31

    题意:

    三场比赛找出每场比赛中收益最大的name和profit,profit按照所给的公式计算。(好像是这样的^_^)

    Code:

    #include<iostream>
    #include<algorithm>
    #include<iomanip>
    
    using namespace std;
    
    int main() {
        double profit = 1.0;
        char arr[3];
        for (int i = 0; i < 3; ++i) {
            char c = 'W';
            double w, t, l, n;
            cin >> w >> t >> l;
            profit *= max(max(w, t), l);
            if (t > w && t > l) c = 'T';
            if (l > w && l > t) c = 'L';
            arr[i] = c;
        }
    
        cout << arr[0];
        for (int i = 1; i < 3; ++i) {
            cout << " " << arr[i];
        }
        cout << " " << fixed << setprecision(2) << (profit * 0.65 - 1) * 2;
    
        return 0;
    }
    

      

    永远渴望,大智若愚(stay hungry, stay foolish)
  • 相关阅读:
    codeforces 589G G. Hiring(树状数组+二分)
    树状数组的小总结
    virtualenv
    Redis备份与恢复
    Linux 网站相关
    MySQL文章参考
    动态执行表不可访问,本会话的自动统计被禁止 。 在执行菜单里你可以禁止统计,或在v$session,v$sesstat 和 v$statname 表里获得select权限
    app已损坏,打不开。你应该将它移到废纸篓
    macos系统用virtualbox安装Linux系统无法设
    Hadoop 分布式部署HDFS-hadoop用户部署
  • 原文地址:https://www.cnblogs.com/h-hkai/p/12587195.html
Copyright © 2011-2022 走看看