zoukankan      html  css  js  c++  java
  • 1092 To Buy or Not to Buy

    Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is Yes, please tell her the number of extra beads she has to buy; or if the answer is No, please tell her the number of beads missing from the string.

    For the sake of simplicity, let's use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.

    figbuy.jpg

    Figure 1

    Input Specification:

    Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

    Output Specification:

    For each test case, print your answer in one line. If the answer is Yes, then also output the number of extra beads Eva has to buy; or if the answer is No, then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.

    Sample Input 1:

    ppRYYGrrYBR2258
    YrR8RrY
    
     

    Sample Output 1:

    Yes 8
    
     

    Sample Input 2:

    ppRYYGrrYB225
    YrR8RrY
    
     

    Sample Output 2:

    No 2

    题意:

    给出两个字符串,判断第二个字符串的每一个字符是否包含于第一个字符串。

    思路:

    用一个map记录每一个字符的个数。(注意:map<char, int>中int的初始值是0)

    Code:

    #include<iostream>
    #include<map>
    
    using namespace std;
    
    int main() {
        string shopOwer, Eva;
        cin >> shopOwer >> Eva;
    
        map<char, int> m;
    
        for (int i = 0; i < shopOwer.length(); ++i) {
            m[shopOwer[i]] += 1;
        }
        int lose = 0;
        for (int i = 0; i < Eva.length(); ++i) {
            if (m[Eva[i]] == 0) lose++;
            else m[Eva[i]]--;
        }
    
        if (lose > 0) {
            cout << "No" << " " << lose << endl;
        } else {
            cout << "Yes" << " " << shopOwer.length()-Eva.length() << endl;
        }
    
        return 0;
    }
    

      

    永远渴望,大智若愚(stay hungry, stay foolish)
  • 相关阅读:
    js调用oc方法 UIWebView 跳 到另一个UIWebView
    可变cell,自适应cell,理解iOS 8中的Self Sizing Cells和Dynamic Type
    设置textField的placeholder字体的颜色,默认是灰色
    设置按钮(UIButton)为圆角矩形
    UITextView限制输入字数
    如何更好地限制一个UITextField的输入长度
    uitableview style类型为Grouped时,去掉上面空白的方法
    python note 01 计算机基础与变量
    Leetcode61.旋转链表
    Leetcode 430. 扁平化多级双向链表
  • 原文地址:https://www.cnblogs.com/h-hkai/p/12618317.html
Copyright © 2011-2022 走看看