zoukankan      html  css  js  c++  java
  • 1142 Maximal Clique

    A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

    Now it is your job to judge if a given subset of vertices can form a maximal clique.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

    After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

    Output Specification:

    For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

    Sample Input:

    8 10
    5 6
    7 8
    6 4
    3 6
    4 5
    2 3
    8 2
    2 7
    5 3
    3 4
    6
    4 5 4 3 6
    3 2 8 7
    2 2 3
    1 1
    3 4 3 6
    3 3 2 1
    
     

    Sample Output:

    Yes
    Yes
    Yes
    Yes
    Not Maximal
    Not a Clique

    题意:

      给出一个无向图,然后再给出这个图里的几个结点判断这几个结点是不是Maximal Clique(最大团)。

    思路:

      暴力穷举。

    Code:

    #include <iostream>
    #include <set>
    #include <vector>
    
    using namespace std;
    
    bool isClique(vector<int>& v, vector<vector<int> >& grap) {
        for (int i = 0; i < v.size(); ++i) {
            for (int j = i + 1; j < v.size(); ++j) {
                if (grap[v[i]][v[j]] == -1) return false;
            }
        }
        return true;
    }
    
    bool isMaxClique(vector<int>& v, vector<vector<int> >& grap) {
        set<int> s(v.begin(), v.end());
        for (int i = 1; i < grap.size(); ++i) {
            bool isMax = false;
            if (s.find(i) == s.end()) {
                for (int j = 0; j < v.size(); ++j) {
                    if (grap[i][v[j]] == -1) {
                        isMax = true;
                        break;
                    }
                }
                if (!isMax) return false;
            }
        }
        return true;
    }
    
    int main() {
        int Nv, Ne;
        cin >> Nv >> Ne;
    
        int v1, v2;
        vector<vector<int> > grap(Nv + 1, vector<int>(Nv + 1, -1));
        for (int i = 0; i < Ne; ++i) {
            cin >> v1 >> v2;
            grap[v1][v2] = grap[v2][v1] = 1;
        }
        int n, k, t;
        cin >> n;
        for (int i = 0; i < n; ++i) {
            cin >> k;
            vector<int> v(k, 0);
            for (int j = 0; j < k; ++j) {
                cin >> v[j];
            }if (isClique(v, grap)) {
                if (isMaxClique(v, grap)) {
                    cout << "Yes" << endl;
                } else {
                    cout << "Not Maximal" << endl;
                }
            } else {
                cout << "Not a Clique" << endl;
            }
        }
    
        return 0;
    }
    永远渴望,大智若愚(stay hungry, stay foolish)
  • 相关阅读:
    跨媒体安全
    kali视频(21-25)学习
    kali视频(26-30)学习
    kali视频(16-20)学习
    kali视频学习(11-15)
    kali视频(1-5)
    使用Metaspoit攻击MS08-067
    web应用程序安全攻防---sql注入和xss跨站脚本攻击
    -区块链-
    TCP/IP网络协议攻击
  • 原文地址:https://www.cnblogs.com/h-hkai/p/12701214.html
Copyright © 2011-2022 走看看