zoukankan      html  css  js  c++  java
  • 1079 Total Sales of Supply Chain

    A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

    Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

    Now given a supply chain, you are supposed to tell the total sales from all the retailers.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains three positive numbers: N (≤), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N−1, and the root supplier's ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

    K​i​​ ID[1] ID[2] ... ID[K​i​​]

    where in the i-th line, K​i​​ is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. K​j​​ being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after K​j​​. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1.

    Sample Input:

    10 1.80 1.00
    3 2 3 5
    1 9
    1 4
    1 7
    0 7
    2 6 1
    1 8
    0 9
    0 4
    0 3
    
     

    Sample Output:

    42.4

    题意:

      第三次见到类似的题目了

    思路:

      用path[]储存该节点的上一个节点,以此来找到root,从而确定中间一共涨价几次,然后再将涨价后的价格与数量相乘,最后求和即可。(但是这样最后一组数据会超时)

    Code:

    #include <bits/stdc++.h>
    
    using namespace std;
    
    int main() {
        int n;
        double p, r;
        cin >> n >> p >> r;
        vector<int> path(n);
        vector<pair<int, int> > product;
        for (int i = 0; i < n; ++i) {
            int k;
            cin >> k;
            if (k == 0) {
                int t;
                cin >> t;
                product.push_back({i, t});
            } else
                for (int j = 0; j < k; ++j) {
                    int t;
                    cin >> t;
                    path[t] = i;
                }
        }
        double sum = 0.0;
        for (int i = 0; i < product.size(); ++i) {
            int id = product[i].first;
            int count = 0;
            while (id != 0) {
                id = path[id];
                count++;
            }
            sum += (pow(1 + r / 100.0, count) * p) * product[i].second;
        }
    
        cout << fixed << setprecision(1) << sum << endl;
    
        return 0;
    }

    看了一下别人的代码发现使用DFS来做的。

    永远渴望,大智若愚(stay hungry, stay foolish)
  • 相关阅读:
    ORA00911: 无效字符
    在创建外键约束时追加on delete cascade或on delete set null
    仿58同城下拉菜单
    经典SQL语句大全
    Substitution 使用方法 页面缓存时的局部刷新
    解决IE8开发人员工具无法使用的问题
    ASP.NET 页面缓存 @ OutputCache
    关于clientWidth、offsetWidth、clientHeight、offsetHeight的测试比较
    调用ThunderAgent 迅雷局域网版的开发
    仿58同城 tips 鼠标悬停提示 类似title、alt
  • 原文地址:https://www.cnblogs.com/h-hkai/p/12805219.html
Copyright © 2011-2022 走看看