zoukankan      html  css  js  c++  java
  • Elven Postman(二叉树)

    Elven Postman

    Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
    Total Submission(s): 1091    Accepted Submission(s): 617


    Problem Description
    Elves are very peculiar creatures. As we all know, they can live for a very long time and their magical prowess are not something to be taken lightly. Also, they live on trees. However, there is something about them you may not know. Although delivering stuffs through magical teleportation is extremely convenient (much like emails). They still sometimes prefer other more “traditional” methods.

    So, as a elven postman, it is crucial to understand how to deliver the mail to the correct room of the tree. The elven tree always branches into no more than two paths upon intersection, either in the east direction or the west. It coincidentally looks awfully like a binary tree we human computer scientist know. Not only that, when numbering the rooms, they always number the room number from the east-most position to the west. For rooms in the east are usually more preferable and more expensive due to they having the privilege to see the sunrise, which matters a lot in elven culture.

    Anyways, the elves usually wrote down all the rooms in a sequence at the root of the tree so that the postman may know how to deliver the mail. The sequence is written as follows, it will go straight to visit the east-most room and write down every room it encountered along the way. After the first room is reached, it will then go to the next unvisited east-most room, writing down every unvisited room on the way as well until all rooms are visited.

    Your task is to determine how to reach a certain room given the sequence written on the root.

    For instance, the sequence 2, 1, 4, 3 would be written on the root of the following tree.

     
    Input
    First you are given an integer T(T10) indicating the number of test cases.

    For each test case, there is a number n(n1000) on a line representing the number of rooms in this tree. n integers representing the sequence written at the root follow, respectively a1,...,an where a1,...,an{1,...,n}.

    On the next line, there is a number q representing the number of mails to be sent. After that, there will be q integers x1,...,xq indicating the destination room number of each mail.
     
    Output
    For each query, output a sequence of move (E or W) the postman needs to make to deliver the mail. For that E means that the postman should move up the eastern branch and W the western one. If the destination is on the root, just output a blank line would suffice.

    Note that for simplicity, we assume the postman always starts from the root regardless of the room he had just visited.
     
    Sample Input
    2 4 2 1 4 3 3 1 2 3 6 6 5 4 3 2 1 1 1
     
    Sample Output
    E WE EEEEE

    题解:精灵族住在一颗倒着的二叉树上,这棵二叉树是从东到西编号,最东边是1,依次类推,邮递员要给精灵送信,每次邮递员都在最底下的点上,让输出邮递员的路径,思想就是建一颗倒着的二叉树,如果编号小就在东边建,也就是右边,大了就建在左边,每次建图直接把路径存上就妥了;

    代码:

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<cmath>
    #include<algorithm>
    #include<vector>
    using namespace std;
    #define mem(x,y) memset(x,y,sizeof(x))
    const int MAXN=1010;
    vector<char>path[MAXN];
    struct Node{
    	Node *L,*R;
    	int nu;
    	Node(int x=0):nu(x){
    		L=NULL;R=NULL;
    	}
    }*rot;
    void inst(int x){
    	Node *p=rot;
    	while(1){
    	if(x>p->nu){
    		path[x].push_back('W');
    		if(p->L==NULL){
    			p->L=new Node(x);
    			break;
    		}
    		else p=p->L;
    	}
    	else{
    			path[x].push_back('E');
    			if(p->R==NULL){
    				p->R=new Node(x);
    				break;
    			}
    			else p=p->R;
    		}
    	}
    }
    int main(){
    	int T,n,q;
    	scanf("%d",&T);
    	while(T--){
    		for(int i=0;i<MAXN;i++)path[i].clear();
    		scanf("%d",&n);
    		int x;
    		scanf("%d",&x);
    		rot=new Node(x);
    		for(int i=1;i<n;i++){
    			scanf("%d",&x);
    			inst(x);
    		}
    		scanf("%d",&q);
    		while(q--){
    			scanf("%d",&x);
    			for(int i=0;i<path[x].size();i++)
    			printf("%c",path[x][i]);
    			puts("");
    		}
    	}
    	return 0;
    }
    

    java:注意java的对象传递是引用类型, 但是tree = new Tree()会给tree重新分配一个jvm地址,这时候tree的改变不会使原值改变,此时变成了值传递,所以想了个思路,就是在类里面对属性复制,也就是newL(),newR()方法;

    代码:

    package com.lanqiao.week1;
    
    import java.util.LinkedList;
    import java.util.Scanner;
    
    public class hdu5444 {
        private static Scanner cin = null;
        static{
            cin = new Scanner(System.in);
        }
        static class Tree{
            public Tree l;
            public Tree r;
            public int value;
            
            public void newL(int v){
                l = new Tree(null, null, v);
            }
            
            public void newR(int v){
                r = new Tree(null, null, v);
            }
            public static void insert(Tree t, int v){
                if(v > t.value){
                    if(t.r != null)
                        insert(t.r, v);
                    else
                        t.newR(v);
                }else{
                    if(t.l != null)
                        insert(t.l, v);
                    else
                        t.newL(v);
                }
            }
            public static void visit(Tree t, int v){
                if(t == null)
                    return;
                if(v == t.value){
                    return;
                }
                if(v > t.value){
                    System.out.print("W");
                    visit(t.r, v);
                }else{
                    System.out.print("E");
                    visit(t.l, v);
                }
            }
            public Tree() {
                super();
            }
            public Tree(Tree l, Tree r, int value) {
                this.l = l;
                this.r = r;
                this.value = value;
            }
        }
        public static void main(String[] args) {
            int T, n, q, a, v;
            T = cin.nextInt();
            while(T-- > 0){
                n = cin.nextInt();
                a = cin.nextInt();
                Tree t = new Tree(null, null, a);
                
                for(int i = 1; i < n; i++){
                    a = cin.nextInt();
                    Tree.insert(t, a);
                }
                q = cin.nextInt();
                //System.out.println(t);
                while(q-- > 0){
                    v = cin.nextInt();
                    Tree.visit(t, v);
                    System.out.println();
                }
            }
        }
    }
  • 相关阅读:
    Mysql数据库中的EXISTS和NOT EXISTS
    (4)事件处理——(2)在页面加载的时候执行任务(Performing tasks on page load)
    SICP 习题 (1.13) 解题总结
    [Usaco2009 Feb]Revamping Trails 堆优化 Dijkstra
    (4)事件处理——(3)代码执行的顺序(Timing of code execution)
    【Android】Handler的应用(一):从服务器端加载JSON数据
    HDU 4498 Function Curve (分段, simpson)
    关于 android Intent 传对象和对象数组的一些操作
    mahout算法源码分析之Collaborative Filtering with ALS-WR 并行思路
    javaScript数据类型与typeof操作符
  • 原文地址:https://www.cnblogs.com/handsomecui/p/4978942.html
Copyright © 2011-2022 走看看