zoukankan      html  css  js  c++  java
  • Brave balloonists 求素因子的个数

    Description

    Ten mathematicians are flying on a balloon over the Pacific ocean. When they are crossing the equator they decide to celebrate this event and open a bottle of champagne. Unfortunately, the cork makes a hole in the balloon. Hydrogen is leaking out and the balloon is descending now. Soon it will fall into the ocean and all the balloonists will be eaten by hungry sharks.
    But not everything is lost yet. One of the balloonists can sacrifice himself jumping out, so that his friends would live a little longer. Only one problem still exists ¾ who is the one to get out. There is a fair way to solve this problem. First, each of them writes an integer ai not less than 1 and not more than 10000. Then they calculate the magic number N that is the number of positive integer divisors of the product a1*a2*...*a10. For example, the number of positive integer divisors of 6 is 4 (they are 1,2,3,6). The hero (a mathematician who will be thrown out) is determined according to the last digit of N. Your task is to find this digit.

    Input

    Input file contains ten numbers separated by a space.

    Output

    Output file should consist of a single digit from 0 to 9 - the last digit of N.

    Sample Input

    1
    2
    6
    1
    3
    1
    1
    1
    1
    1
    

    Sample Output

    9

    #include<stdio.h>
    #include <iostream>
    #include<cmath>
    #include <algorithm>
    using namespace std;
    int save[10000];
    int main()
    {
    	int a[10],i,ans,t,sum=1,k;
    	for(k=0;k<10;k++)
    	{
    		scanf("%d",&a[k]);
    		t=a[k];
    		for(i=2;i<=t;i++)
    		{
    			while(t%i==0)
    			{
    				save[i]++;
    				t=t/i;
    			}
    		}
    	}
    	for(i=0;i<=10000;i++)
    		if(save[i]!=0)
    		   sum*=save[i]+1;
    	ans=sum%10;
    	printf("%d\n",ans);
    	return 0;
    } 
  • 相关阅读:
    Flink 双流合并之connect Demo2
    Flink 双流合并之connect Demo1
    Flink 双流合并Join
    Flink状态保存CheckPoint
    Flink状态之OperatorState
    Flink状态之AggregateState
    Flink状态之ReduceState
    Flink状态之MapState
    Flink状态之KeyedListState
    大数据框架环境安装与配置01--服务器基本设置
  • 原文地址:https://www.cnblogs.com/heqinghui/p/2605522.html
Copyright © 2011-2022 走看看