zoukankan      html  css  js  c++  java
  • Raising Modulo Numbers

    /*Raising Modulo Numbers
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 3555   Accepted: 1964

    Description

    People are different. Some secretly read magazines full of interesting girls' pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow:
    Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions AiBi from all players including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players' experience it is possible to increase the difficulty by choosing higher numbers.
    You should write a program that calculates the result and is able to find out who won the game.

    Input

    The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.

    Output

    For each assingnement there is the only one line of output. On this line, there is a number, the result of expression

    (A1B1+A2B2+ ... +AHBH)mod M.

    Sample Input

    3
    16
    4
    2 3
    3 4
    4 5
    5 6
    36123
    1
    2374859 3029382
    17
    1
    3 18132
    

    Sample Output

    2
    13195
    13
    */
    #include<iostream>
    #include<stdio.h>
    #include<algorithm>
    #include<cmath>
    using namespace std;
    int powmod (int a,int b,int n)
    {
     if(b==0)return 1;
     int k=1;
     while(b>=1)
     {
      if(b%2!=0)k=a*k%n;
      a=((a%n)*(a%n))%n;//算a^2 mod n因为计算机可以保存中间结果,减少计算时间。
      b/=2;
     }
     return k;
    }
    int main()
    {
     int a,b,t,n,k,sum,i;
     scanf("%d",&t);
     while(t--)
     {
      sum=0;
      scanf("%d%d",&n,&k);
      for(i=0;i<k;i++)
      {
       scanf("%d%d",&a,&b);
       sum+=powmod(a,b,n);
       sum%=n;
      }
      printf("%d\n",sum);
     }
     return 0;
    }
  • 相关阅读:
    牛客网提高五练习
    [BZOJ2820]YY的GCD
    [BZOJ2301][HAOI2011]Problem B
    [板子]快速读入
    复选框改成开关样式,滑动切换(纯css实现)
    rem的使用方法
    html添加删除输入框
    jq 实现全选反选,获取选中的值
    cdn引入vant框架使用在html页面使用
    为什么vuejs里面定义的template模板里定义的多个元素只显示一个
  • 原文地址:https://www.cnblogs.com/heqinghui/p/2605894.html
Copyright © 2011-2022 走看看