zoukankan      html  css  js  c++  java
  • 匹配,矩阵相乘,堆栈

    /*Problem E

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)

    Total Submission(s) : 1   Accepted Submission(s) : 1

    Font: Times New Roman | Verdana | Georgia

     Font Size: ← →

    Problem Description

     Matrix multiplication problem is a typical example of dynamical programming.

    Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose. For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix. There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C). The first one takes 15000 elementary multiplications, but the second one only 3500.

    Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.

    Input

     Input consists of two parts: a list of matrices and a list of expressions. The first line of the input file contains one integer n (1 <= n <= 26), representing the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix. The second part of the input file strictly adheres to the following syntax (given in EBNF):

    SecondPart = Line { Line } <EOF> Line = Expression <CR> Expression = Matrix | "(" Expression Expression ")" Matrix = "A" | "B" | "C" | ... | "X" | "Y" | "Z"  

    Output

     For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

    Sample Input

    9 A 50 10 B 10 20 C 20 5 D 30 35 E 35 15 F 15 5 G 5 10 H 10 20 I 20 25 A B C (AA) (AB) (AC) (A(BC)) ((AB)C) (((((DE)F)G)H)I) (D(E(F(G(HI))))) ((D(EF))((GH)I))

     Sample Output

    0 0 0 error 10000 error 3500 15000 40500 47500 15125

    #include <iostream>
    #include <algorithm>
    #include <stdio.h>
    #include <string.h>
    #include <cmath>
    #include <stack>//栈头文件
    using namespace std;
    struct node
    {
        int m,n;
      //  bool f;
    };
    node hash[200];
    char s[1000];
    int main()
    {
        int i,n,sum;
        char c;
        bool b;
        scanf("%d",&n);
        while(n--)
        {
           getchar();//清除缓存
           scanf("%c",&c);
           scanf("%d%d",&hash[c].m,&hash[c].n);
        }
         node temp,temp1;
        while(scanf("%s",s)!=EOF)
        {   sum=0;b=1;
            stack<char> s1;//字符栈
            stack<node> s2;//结构体栈
            for(i=0;s[i]!='\0';i++)
            {
                if(s[i]=='(')
                   s1.push(s[i]);
                else if(s[i]==')')
                     {
                         c=s1.top();
                         s1.pop();
                         s1.pop();
                         while(!s1.empty()&&s1.top()!='(')
                               {
                                  temp=s2.top();
                                  s2.pop();
                                  temp1=s2.top();
                                 if(temp1.n!=temp.m)
                                 {
                                     b=0;break;
                                 }
                                  sum+=temp1.m*temp1.n*temp.n;
                                  temp1.n=temp.n;
                                  s2.pop();
                                  s2.push(temp1);
                                  s1.pop();
                                }
                           s1.push(c);
                     }
                     else
                     {
                         if(!s1.empty()&&s1.top()!='(')
                         {
                             temp=s2.top();
                             if(temp.n!=hash[s[i]].m)
                             {
                                 b=0;break;
                             }
                             sum+=temp.m*temp.n*hash[s[i]].n;
                             temp.n=hash[s[i]].n;
                             s2.pop();
                             s2.push(temp);
                         }
                         else
                         {
                             s2.push(hash[s[i]]);
                             s1.push('#');
                         }
                     }
            }
            if(b)
              printf("%d\n",sum);
            else
             printf("error\n");
        }
        return 0;
    }

  • 相关阅读:
    HotSpot 的垃圾收集器
    HTML5之日历控件
    设计模式之抽象工厂模式
    设计模式之工厂模式
    设计模式之单例模式
    JavaScript实现input输入框限制输入值的功能
    微信公众号二维码获取
    mybatis的一对多,多对一,以及多对对的配置和使用
    kindeditor在Java项目中的应用以及图片上传配置
    Spring和quartz整合的入门使用教程
  • 原文地址:https://www.cnblogs.com/heqinghui/p/2614252.html
Copyright © 2011-2022 走看看