zoukankan      html  css  js  c++  java
  • HDU1233:还是畅通工程(最小生成树)

    还是畅通工程

    Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 63196    Accepted Submission(s): 28696

    题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1233

    Description:

    某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。

    Input:

    测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
    当N为0时,输入结束,该用例不被处理。

    Output:

    对每个测试用例,在1行里输出最小的公路总长度。

    Sample Input:

    3 1 2 1 1 3 2 2 3 4 4 1 2 1 1 3 4 1 4 1 2 3 3 2 4 2 3 4 5 0

    Sample Output:

    3 5

    题解:

    模板题。

    代码如下:

    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <iostream>
    #include <queue>
    using namespace std;
    typedef long long ll;
    const int N = 105;
    int n;
    struct Edge{
        int u,v,w;
        bool operator < (const Edge &A)const{
            return w<A.w;
        }
    }e[N*N];
    int f[N];
    int find(int x){
        return f[x]==x?f[x]:f[x]=find(f[x]);
    }
    int Kruskal(){
        int ans=0;
        for(int i=0;i<=n+1;i++) f[i]=i;
        for(int i=1;i<=n*(n-1)/2;i++){
            int fx=find(e[i].u),fy=find(e[i].v);
            if(fx==fy) continue ;
            f[fx]=fy;
            ans+=e[i].w;
        }
        return ans ;
    }
    int main(){
        while(~scanf("%d",&n)){
            if(n==0) break;
            for(int i=1;i<=n*(n-1)/2;i++){
                int u,v,w;
                scanf("%d%d%d",&u,&v,&w);
                e[i]=Edge{u,v,w};
            }
            sort(e+1,e+n*(n-1)/2+1);
            cout<<Kruskal()<<endl;
        }
        return 0;
    }
  • 相关阅读:
    SonarQube代码质量管理平台安装与配置
    特殊字符大全
    测试“用户登录”功能
    通用测试用例大全
    k8s dashboard 部署并使用 kubeconfig 登陆
    k8s cert-manager 部署
    nginx ingress部署
    Harbor 安装
    kubernetes 高可用集群1.14 部署
    shell 免密远程执行
  • 原文地址:https://www.cnblogs.com/heyuhhh/p/10372213.html
Copyright © 2011-2022 走看看