zoukankan      html  css  js  c++  java
  • POJ2234:Matches Game(Nim博弈)

    Matches Game

    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 12325   Accepted: 7184

    题目链接:http://poj.org/problem?id=2234

    Description:

    Here is a simple game. In this game, there are several piles of matches and two players. The two player play in turn. In each turn, one can choose a pile and take away arbitrary number of matches from the pile (Of course the number of matches, which is taken away, cannot be zero and cannot be larger than the number of matches in the chosen pile). If after a player’s turn, there is no match left, the player is the winner. Suppose that the two players are all very clear. Your job is to tell whether the player who plays first can win the game or not.

    Input:

    The input consists of several lines, and in each line there is a test case. At the beginning of a line, there is an integer M (1 <= M <=20), which is the number of piles. Then comes M positive integers, which are not larger than 10000000. These M integers represent the number of matches in each pile.

    Output:

    For each test case, output "Yes" in a single line, if the player who play first will win, otherwise output "No".

    Sample Input:

    2 45 45
    3 3 6 9

    Sample Output:

    No
    Yes

    题意:

    给出n堆石子,每一堆有相应的个数,然后问是否先手必胜。

    题解:

    Nim博弈模板题。

    代码如下:

    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <iostream>
    #include <cmath>
    using namespace std;
    typedef long long ll;
    const int N = 25;
    int n;
    int a[N];
    int main(){
        while(scanf("%d",&n)!=EOF){
            int x = 0;
            for(int i=1;i<=n;i++){
                scanf("%d",&a[i]);
                x^=a[i];
            }
            int f = 0;
            for(int i=1;i<=n;i++){
                if((a[i]^x)<a[i]) f=1;
            }
            if(f) cout<<"Yes"<< '
    ';
            else cout<<"No"<<'
    ';
        }
    
        return 0;
    }
  • 相关阅读:
    Integer类_java_1
    Pytest使用随笔_1_"no tests ran"
    postgres执行计划_1_索引
    Jprofile使用随笔_2_内存泄漏
    leetcode76. Minimum Window Substring
    leetcode87. Scramble String
    hihocoder1310 岛屿
    leetcode644. Maximum Average Subarray II
    leetcode132. Palindrome Partitioning II
    leetcode143. Reorder List
  • 原文地址:https://www.cnblogs.com/heyuhhh/p/10574688.html
Copyright © 2011-2022 走看看