zoukankan      html  css  js  c++  java
  • uva 10820 (筛法构造欧拉函数)

                      send a table

        When participating in programming contests, you sometimes face the following problem: You know
    how to calcutale the output for the given input values, but your algorithm is way too slow to ever
    pass the time limit. However hard you try, you just can’t discover the proper break-off conditions that
    would bring down the number of iterations to within acceptable limits.
        Now if the range of input values is not too big, there is a way out of this. Let your PC rattle for half
    an hour and produce a table of answers for all possible input values, encode this table into a program,
    submit it to the judge, et voila: Accepted in 0.000 seconds! (Some would argue that this is cheating,
    but remember: In love and programming contests everything is permitted).
        Faced with this problem during one programming contest, Jimmy decided to apply such a ’technique’.
    But however hard he tried, he wasn’t able to squeeze all his pre-calculated values into a program
    small enough to pass the judge. The situation looked hopeless, until he discovered the following property
    regarding the answers: the answers where calculated from two integers, but whenever the two
    input values had a common factor, the answer could be easily derived from the answer for which the
    input values were divided by that factor. To put it in other words:
        Say Jimmy had to calculate a function Answer(x, y) where x and y are both integers in the range
    [1, N]. When he knows Answer(x, y), he can easily derive Answer(k ∗ x, k ∗ y), where k is any integer
    from it by applying some simple calculations involving Answer(x, y) and k.
        For example if N = 4, he only needs to know the answers for 11 out of the 16 possible input value
    combinations: Answer(1, 1), Answer(1, 2), Answer(2, 1), Answer(1, 3), Answer(2, 3), Answer(3, 2),
    Answer(3, 1), Answer(1, 4), Answer(3, 4), Answer(4, 3) and Answer(4, 1). The other 5 can be derived
    from them (Answer(2, 2), Answer(3, 3) and Answer(4, 4) from Answer(1, 1), Answer(2, 4) from
    Answer(1, 2), and Answer(4, 2) from Answer(2, 1)). Note that the function Answer is not symmetric,
    so Answer(3, 2) can not be derived from Answer(2, 3).
        Now what we want you to do is: for any values of N from 1 upto and including 50000, give the
    number of function Jimmy has to pre-calculate.
    Input
    The input file contains at most 600 lines of inputs. Each line contains an integer less than 50001 which
    indicates the value of N. Input is terminated by a line which contains a zero. This line should not be
    processed.
    Output

    For each line of input produce one line of output. This line contains an integer which indicates how
    many values Jimmy has to pre-calculate for a certain value of N.
    Sample Input
    2
    5
    0
    Sample Output
    3
    19

    题解:输入一个数n,有多少个二元组(x,y)满足:1<=x,y<=n,且x和y互素。不难发现除了(1,1)之外,其他二元组的x和y都不相等。设满足x<y的二元组有a【n】个,那么答案就是2*a【n】-1,因为(1,1)时重复了一个1。

    #include <iostream>
    #include<cstring>
    using namespace std;
    int a[50001];
    int sums[50001];
    int f[50001];
    int n;
    int main()
    {
        memset(a,0,sizeof(a));
        a[1]=1;
        for (int i = 2 ; i < 50001 ; ++ i)
            if (!a[i])
            {
                for (int j = i ; j < 50001 ; j += i)
                {
                    if(!a[j])
                    a[j] = j;
                    a[j] = a[j]/i*(i-1);
                }
            }
    
        sums[0] = 0;
        for (int i = 1 ; i < 50001 ; ++ i)
            sums[i] = sums[i-1]+a[i];
        while (cin >> n && n)
            cout << 2*sums[n]-1 << endl;
    
        return 0;
    }
  • 相关阅读:
    ubuntu20.04安装python pip
    linux tar包追加问题
    [Linux]主机无法ping通虚拟机,但虚拟机却可以ping通主机
    安装pygraphviz/graphviz报错
    elasticsearch Delete (根据条件删除)
    python2 vs python3的区别汇总
    python实现elasticsearch的update操作,不改变原数据,增加字段,或者查询更新
    python bulk批量保存elasticsearch数据
    python rpc 简单实现自带包xmlrpc
    Python获取当前运行函数的名称、类方法名称
  • 原文地址:https://www.cnblogs.com/hfc-xx/p/4745249.html
Copyright © 2011-2022 走看看