zoukankan      html  css  js  c++  java
  • HDU 5074 Hatsune Miku

    Hatsune Miku

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
    Total Submission(s): 226    Accepted Submission(s): 173


    Problem Description
    Hatsune Miku is a popular virtual singer. It is very popular in both Japan and China. Basically it is a computer software that allows you to compose a song on your own using the vocal package.

    Today you want to compose a song, which is just a sequence of notes. There are only m different notes provided in the package. And you want to make a song with n notes.


    Also, you know that there is a system to evaluate the beautifulness of a song. For each two consecutive notes a and b, if b comes after a, then the beautifulness for these two notes is evaluated as score(a, b).

    So the total beautifulness for a song consisting of notes a1, a2, . . . , an, is simply the sum of score(ai, ai+1) for 1 ≤ i ≤ n - 1.

    Now, you find that at some positions, the notes have to be some specific ones, but at other positions you can decide what notes to use. You want to maximize your song’s beautifulness. What is the maximum beautifulness you can achieve?
     
    Input
    The first line contains an integer T (T ≤ 10), denoting the number of the test cases.

    For each test case, the first line contains two integers n(1 ≤ n ≤ 100) and m(1 ≤ m ≤ 50) as mentioned above. Then m lines follow, each of them consisting of m space-separated integers, the j-th integer in the i-th line for score(i, j)( 0 ≤ score(i, j) ≤ 100). The next line contains n integers, a1, a2, . . . , an (-1 ≤ ai ≤ m, ai ≠ 0), where positive integers stand for the notes you cannot change, while negative integers are what you can replace with arbitrary notes. The notes are named from 1 to m.
     
    Output
    For each test case, output the answer in one line.
     
    Sample Input
    2
    5 3
    83 86 77
    15 93 35
    86 92 49
    3 3 3 1 2
     
    10 5
    36 11 68 67 29
    82 30 62 23 67
    35 29 2 22 58
    69 67 93 56 11
    42 29 73 21 19
    -1 -1 5 -1 4 -1 -1 -1 4 -1
     
    Sample Output
    270
    625
     

    这条题目是我在鞍山现场赛切掉的一条水DP 。

    给出一个矩阵mp[][] , 对于序列a(1 <= i < n-1 ) 总得分为 sigma ( mp[ a[i] ][ a[i+1] ] ) .

    维护一个 dp[i][j] 表示a[i]中第i个数,数字为j的最大得分

    当a[i] == -1 时可变。 

    然后当某个a[i]为-1时候直接枚举 1 ~ m去进行状态转移即可~~

    #include <iostream>
    #include <cmath>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    using namespace std ;
    const int N = 110;
    typedef long long LL;
    LL dp[N][N], mp[N][N] , a[N];
    
    void run()
    {
        int n , m ;
        cin >> n >> m ; 
        memset( dp , 0 ,sizeof dp );
        for( int i = 1 ; i <= m ; ++i ){
            for( int j = 1; j <= m ; ++j ){
                cin >> mp[i][j];
            }
        }
        for(int i =1 ; i <= n ; ++i ) cin >> a[i];
        for( int i = 2 ; i <= n ; ++i ){
            if( a[i] == -1 ){
                for( int j = 1 ; j <= m ; ++j ){
                    if( a[i-1] == -1 ){
                        for( int k = 1; k <= m ; ++k ){
                            dp[i][j] = max( dp[i][j] , dp[i-1][k] + mp[k][j] );
                        }
                    }
                    else {
                        dp[i][j] = max( dp[i][j] , dp[i-1][ a[i-1] ] + mp[ a[i-1] ][j] );
                    }
                }
            }
            else{
                if( a[i-1] == -1 ){
                    for( int k = 1; k <= m ; ++k ){
                        dp[i][a[i]] = max( dp[i][a[i]] , dp[i-1][k] + mp[k][a[i]] );
                    }
                }
                else {
                    dp[i][ a[i] ] = max( dp[i][ a[i] ] , dp[i-1][ a[i-1] ] + mp[ a[i-1] ][a[i]] );
                }
            }
        }
        LL ans = 0 ;
        if( a[n] == -1 ){
            for( int i =1 ; i <= m ; ++i ) ans = max( ans , dp[n][i] );
        }
        else ans = dp[n][ a[n] ];
        cout << ans <<endl;
    }
    int main()
    {
        #ifdef LOCAL
            freopen("in.txt","r",stdin);
        #endif // LOCAL
        ios::sync_with_stdio(false);
        int _ ;
        cin >> _;
        while( _-- )run();
    }
    only strive for your goal , can you make your dream come true ?
  • 相关阅读:
    蓝桥杯训练 | 枚举,模拟与排序 | 04
    linux全套 | Linux模板机器安装 | 18
    linux全套 | Shell编程 | 16
    MySQL主从复制延迟解决方案
    MySQL异地备份方案
    MYSQL必知必会-where语句
    MySQL常见面试题-概念题
    入门-MySQL查询语句的45道练习
    20145234黄斐《信息安全系统设计基础》第0周学习总结
    OpenGL代码学习(2)
  • 原文地址:https://www.cnblogs.com/hlmark/p/4049131.html
Copyright © 2011-2022 走看看