zoukankan      html  css  js  c++  java
  • 【刷题】HDU 4966 GGS-DDU

    Problem Description

    Do you think this is a strange problem name? That is because you don't know its full name---'Good Good Study and Day Day Up!". Very famous sentence! Isn't it?

    Now "GGS-DDU" is lzqxh's target! He has N courses and every course is divided into a plurality of levels. Just like College English have Level 4 and Level 6.

    To simplify the problem, we suppose that the i-th course has Levels from level 0 to level a[i]. And at the beginning, lzqxh is at Level 0 of every course. Because his target is "GGS-DDU", lzqxh wants to reach the highest Level of every course.

    Fortunately, there are M tutorial classes. The i-th tutoial class requires that students must reach at least Level L1[i] of course c[i] before class begins. And after finishing the i-th tutorial class, the students will reach Level L2[i] of course d[i]. The i-th tutoial class costs lzqxh money[i].

    For example, there is a tutorial class only students who reach at least Level 5 of "Tiyu" can apply. And after finishing this class, the student's "MeiShu" will reach Level 10 if his "MeiShu"'s Level is lower than 10. (Don't ask me why! Supernatural class!!!")

    Now you task is to help lzqxh to compute the minimum cost!

    Input

    The input contains multiple test cases.

    The first line of each case consists of two integers, N (N<=50) and M (M<=2000).
    The following line contains N integers, representing a[1] to a[N]. The sum of a[1] to a[N] will not exceed 500.
    The next M lines, each have five integers, indicating c[i], L1[i], d[i], L2[i] and money[i] (1<=c[i], d[i]<=N, 0<=L1[i]<=a[c[i]], 0<=L2[i]<=a[d[i]], money[i]<=1000) for the i-th tutorial class. The courses are numbered from 1 to N.

    The input is terminated by N = M = 0.

    Output

    Output the minimum cost for achieving lzqxh's target in a line. If his target can't be achieved, just output -1.

    Sample Input

    3 4
    3 3 1
    1 0 2 3 10
    2 1 1 2 10
    1 2 3 1 10
    3 1 1 3 10
    0 0

    Sample Output

    40

    Description(CHN)

    有n种科目,每个科目有等级0~a[i]。开始时,每个科目都是0级。现在要选择一些课程进行学习使得每一个科目都达到最高等级。有m节课。对于每门课给出c1[i],L1[i],c2[i],L2[i],money[i],要选择这门课要求科目c1[i]的等级不小于L1[i],可以使科目c2[i]的等级升为L2[i],花费金钱money[i]。请计算最小花费是多少。

    Solution

    最小树形图
    每门科目每个等级都设为一个点
    所有课都对应一条权值为花费金钱的有向边
    然后对于每一门课,将它的每个等级都向低一级连一条 (0) 费的边,那么只要到达高等级,低等级一定选到,并且不会影响最终代价
    于是建个超级源点跑最小树形图就好了

    #include<bits/stdc++.h>
    #define ui unsigned int
    #define ll long long
    #define db double
    #define ld long double
    #define ull unsigned long long
    const int MAXN=600+10,MAXM=MAXN*MAXN,inf=0x3f3f3f3f;
    int n,m,sum[MAXN],vis[MAXN],pre[MAXN],in[MAXN],bel[MAXN],snt,s,a[MAXN];
    struct node{
    	int u,v,k;
    };
    node side[MAXM];
    template<typename T> inline void read(T &x)
    {
    	T data=0,w=1;
    	char ch=0;
    	while(ch!='-'&&(ch<'0'||ch>'9'))ch=getchar();
    	if(ch=='-')w=-1,ch=getchar();
    	while(ch>='0'&&ch<='9')data=((T)data<<3)+((T)data<<1)+(ch^'0'),ch=getchar();
    	x=data*w;
    }
    template<typename T> inline void write(T x,char ch='')
    {
    	if(x<0)putchar('-'),x=-x;
    	if(x>9)write(x/10);
    	putchar(x%10+'0');
    	if(ch!='')putchar(ch);
    }
    template<typename T> inline void chkmin(T &x,T y){x=(y<x?y:x);}
    template<typename T> inline void chkmax(T &x,T y){x=(y>x?y:x);}
    template<typename T> inline T min(T x,T y){return x<y?x:y;}
    template<typename T> inline T max(T x,T y){return x>y?x:y;}
    inline int id(int les,int lvl)
    {
    	return sum[les-1]+lvl+1;
    }
    inline int solve(int rt,int n)
    {
    	int res=0;
    	while(true)
    	{
    		for(register int i=1;i<=n;++i)in[i]=inf;
    		for(register int i=1;i<=snt;++i)
    			if(side[i].u!=side[i].v&&in[side[i].v]>side[i].k)in[side[i].v]=side[i].k,pre[side[i].v]=side[i].u;
    		for(register int i=1;i<=n;++i)
    			if(i!=rt&&in[i]==inf)return -1;
    		int cnt=0;
    		memset(vis,0,sizeof(vis));
    		memset(bel,0,sizeof(bel));
    		in[rt]=0;
    		for(register int i=1,j;i<=n;++i)
    		{
    			res+=in[i];j=i;
    			while(j!=rt&&vis[j]!=i&&!bel[j])vis[j]=i,j=pre[j];
    			if(j!=rt&&!bel[j])
    			{
    				bel[j]=++cnt;
    				for(register int k=pre[j];k!=j;k=pre[k])bel[k]=cnt;
    			}
    		}
    		if(!cnt)break;
    		for(register int i=1;i<=n;++i)
    			if(!bel[i])bel[i]=++cnt;
    		for(register int i=1,u,v;i<=snt;++i)
    		{
    			u=side[i].u,v=side[i].v;
    			side[i].u=bel[u],side[i].v=bel[v];
    			if(bel[u]^bel[v])side[i].k-=in[v];
    		}
    		n=cnt;
    		rt=bel[rt];
    	}
    	return res;
    }
    int main()
    {
    	while(scanf("%d%d",&n,&m)!=EOF)
    	{
    		if(!n&&!m)break;
    		snt=0;
    		for(register int i=1;i<=n;++i)read(a[i]),sum[i]=sum[i-1]+a[i]+1;
    		for(register int i=1;i<=m;++i)
    		{
    			int c1,l1,c2,l2,money;read(c1);read(l1);read(c2);read(l2);read(money);
    			side[++snt]=(node){id(c1,l1),id(c2,l2),money};
    		}
    		for(register int i=1;i<=n;++i)
    			for(register int j=a[i];j>=1;--j)side[++snt]=(node){id(i,j),id(i,j-1),0};
    		s=sum[n]+1;
    		for(register int i=1;i<=n;++i)side[++snt]=(node){s,id(i,0),0};
    		write(solve(s,s),'
    ');
    	}
    	return 0;
    }
    
  • 相关阅读:
    Windows设置多用户同时远程登录
    Scala配置环境变量windows
    Java学习|强引用,软引用,弱引用,幻想引用有什么区别?
    Java学习|Exception和Error有什么区别?
    关于异常处理的几点建议
    win Server 2008 笔记
    .Net 初步学习笔记之三---变量
    认识与入门 MarkDown 标记语言
    C# winform基础 1、Timer不起作用 2、 设置图片透明
    IIS启动失败,启动Windows Process Activation Service时,出现错误13:数据无效 ;HTTP 错误 401.2
  • 原文地址:https://www.cnblogs.com/hongyj/p/9285748.html
Copyright © 2011-2022 走看看