zoukankan      html  css  js  c++  java
  • HDU Humble Numbers

    Problem Description
    A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

    Write a program to find and print the nth element in this sequence
     
    Input
    The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
     
    Output
    For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
     
    Sample Input
    1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
     
    Sample Output
    The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.
     
    一开始不知道后缀的特点,导致wrong, 利用data[++index]=min(data[first]*2,data[second]*3,data[third]*5,data[forth]*7),的思想

    #include<stdio.h>
    #include<math.h>
    int main(){
    long long data[5848];
    int index=1,first=1,second=1,third=1,forth=1,n;
    while(1){
    if(index==5843)
    break;
    data[1]=1;
    int temp,temp1,temp2;
    temp1=data[first]*2<=data[second]*3?data[first]*2:data[second]*3;
    temp2=data[third]*5<=data[forth]*7?data[third]*5:data[forth]*7;
    temp=temp1<=temp2?temp1:temp2;
    if(temp==data[first]*2)
    first++;
    if(temp==data[second]*3)
    second++;
    if(temp==data[third]*5)
    third++;
    if(temp==data[forth]*7)
    forth++;
    if(temp>data[index]){
    //printf("%d ",data[index]);
    data[++index]=temp;
    }
    }
    while(~scanf("%d",&n)){
    if(n==0)break;
    if(n%10==1&&n%100!=11){
    printf("The %dst humble number is %d. ",n,data[n]);
    }else if(n%10==2&&n%100!=12){
    printf("The %dnd humble number is %d. ",n,data[n]);
    }else if(n%10==3&&n%100!=13){
    printf("The %drd humble number is %d. ",n,data[n]);
    }else{
    printf("The %dth humble number is %d. ",n,data[n]);
    }
    }
    return 0;
    }

  • 相关阅读:
    39 多线程(十一)——ThreadLocal
    38 多线程(十)——volatile 数据同步
    Linux内存描述之内存区域zone–Linux内存管理(三)
    Linux内存描述之内存节点node–Linux内存管理(二)
    Linux内存描述之概述--Linux内存管理(一)
    服务器体系(SMP, NUMA, MPP)与共享存储器架构(UMA和NUMA)
    乐观
    乱七八糟的学习资料汇总(python3.x,pyqt,svn,git)
    Linux学习资料网站汇总链接(持续更新ing)
    浅析十大常见排序(含C++代码)
  • 原文地址:https://www.cnblogs.com/hoojjack/p/3979560.html
Copyright © 2011-2022 走看看