zoukankan      html  css  js  c++  java
  • PAT Advanced 1090 Highest Price in Supply Chain (25) [树的遍历]

    题目

    A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)–everyone involved in moving a product from supplier to customer. Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle. Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.
    Input Specification:
    Each input file contains one test case. For each case, The first line contains three positive numbers: N(<=10^5), the total number of the members in the supply chain (and hence they are numbered from 0 to N-1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number Si is the index of the supplier for the i-th member. Sroot for the root supplier is defined to be -1. All the numbers in a line are separated by a space.
    Output Specification:
    For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 1010.
    Sample Input:
    9 1.80 1.00
    1 5 4 4 -1 4 5 3 6
    Sample Output:
    1.85 2

    题目分析

    已知所有非叶子节点的所有子节点,求最大层数和最大层叶子结点数

    解题思路

    思路 01

    1. dfs遍历树,参数p记录当前节点所在层的价格,max_p记录最大层,max_p_num记录最大层叶子结点数

    思路 02

    1. bfs遍历树,double ps[n]数组记录当前节点所在层的价格,max_p记录最大层,max_p_num记录最大层叶子结点数

    Code

    Code 01(dfs)

    #include <iostream>
    #include <vector>
    using namespace std;
    const int maxn=100000;
    double p,r,max_p;
    vector<int> nds[maxn];
    int max_p_num; 
    void dfs(int index, double p) {
    	if(nds[index].size()==0) {
    		if(max_p<p) {
    			max_p=p;
    			max_p_num=1;
    		} else if(max_p==p) {
    			max_p_num++;
    		}
    		return;
    	}
    	for(int i=0; i<nds[index].size(); i++) {
    		dfs(nds[index][i],p*(1+r*0.01));
    	}
    }
    int main(int argc, char * argv[]) {
    	int n,rid,root;
    	scanf("%d %lf %lf", &n,&p,&r);
    	for(int i=0; i<n; i++) {
    		scanf("%d",&rid);
    		if(rid==-1)root=i;
    		else nds[rid].push_back(i);
    	}
    	dfs(root,p);
    	printf("%.2f %d",max_p,max_p_num); 
    	return 0;
    }
    

    Code 02(bfs)

    #include <iostream>
    #include <vector>
    #include <queue>
    using namespace std;
    const int maxn=100000;
    double p,r,max_p,ps[maxn];
    vector<int> nds[maxn];
    int max_p_num,root;
    void bfs() {
    	queue<int> q;
    	q.push(root);
    	while(!q.empty()) {
    		int now = q.front();
    		q.pop(); 
    		if(nds[now].size()==0) {
    			if(max_p==ps[now]) {
    				max_p_num++;
    			} else if(max_p<ps[now]) {
    				max_p=ps[now];
    				max_p_num=1;
    			}
    		} else {
    			for(int i=0; i<nds[now].size(); i++) {
    				ps[nds[now][i]]=ps[now]*(1+r*0.01);
    				q.push(nds[now][i]);
    			}
    		}
    	}
    }
    int main(int argc,char * argv[]) {
    	int n,rid;
    	scanf("%d %lf %lf", &n,&p,&r);
    	for(int i=0; i<n; i++) {
    		scanf("%d",&rid);
    		if(rid==-1)root=i;
    		else nds[rid].push_back(i);
    	}
    	ps[root]=p;
    	bfs();
    	printf("%.2f %d",max_p,max_p_num);
    	return 0;
    }
    
  • 相关阅读:
    转载:【Oracle 集群】RAC知识图文详细教程(三)--RAC工作原理和相关组件
    转载:【Oracle 集群】RAC知识图文详细教程(一)--集群概念介绍
    转载:【Oracle 集群】RAC知识图文详细教程(二)--Oracle 集群概念及原理
    题目总结
    面试题(包含答案)
    ElementUI动态表格数据转换formatter
    父组件搜索列表 给 子组件传值问题
    项目提取公共接口方法
    数组常用方法总结
    vue全局注册
  • 原文地址:https://www.cnblogs.com/houzm/p/12327922.html
Copyright © 2011-2022 走看看