zoukankan      html  css  js  c++  java
  • Quicksum

     

    Quicksum

    时间限制:3000 ms  |  内存限制:65535 KB
    难度:2
     
    描述

    A checksum is an algorithm that scans a packet of data and returns a single number. The idea is that if the packet is changed, the checksum will also change, so checksums are often used for detecting transmission errors, validating document contents, and in many other situations where it is necessary to detect undesirable changes in data.

    For this problem, you will implement a checksum algorithm called Quicksum. A Quicksum packet allows only uppercase letters and spaces. It always begins and ends with an uppercase letter. Otherwise, spaces and letters can occur in any combination, including consecutive spaces.

    A Quicksum is the sum of the products of each character's position in the packet times the character's value. A space has a value of zero, while letters have a value equal to their position in the alphabet. So, A=1, B=2, etc., through Z=26. Here are example Quicksum calculations for the packets "ACM" and "MID CENTRAL":

    ACM: 1*1  + 2*3 + 3*13 = 46
    
    MID CENTRAL: 1*13 + 2*9 + 3*4 + 4*0 + 5*3 + 6*5 + 7*14 + 8*20 +
    9*18 + 10*1 + 11*12 = 650
     
    输入
    The input consists of one or more packets followed by a line containing only # that signals the end of the input. Each packet is on a line by itself, does not begin or end with a space, and contains from 1 to 300 characters.
    输出
    For each packet, output its Quicksum on a separate line in the output.
    样例输入
    ACM
    MID CENTRAL
    REGIONAL PROGRAMMING CONTEST
    ACN
    A C M
    ABC
    BBC
    #
    样例输出
    46
    650
    4690
    49
    75
    14
    15

    #include<iostream>
    #include<cstring>
    #include<cstdio>
    using namespace std;

    int main()
    {
      int str,i,k;
      char s[303];

      while(gets(s))
      {
        if(s[0]=='#')
      break;
     str=strlen(s);
     int sum=0;
     for(i=0;i<str;i++)
     {
       if(s[i]==' ') k=0; else k=(int)(s[i]-'@') ;
       sum+=(i+1)*k;
     }
     cout<<sum<<endl;
      }
      return 0;
    }

  • 相关阅读:
    python函数续
    模拟数据库查询操作
    文件处理
    字符编码
    python函数
    ACM-ICPC 2018 南京赛区网络预赛Skr
    bzoj3676: [Apio2014]回文串 pam
    Wannafly挑战赛23B游戏
    bzoj4804: 欧拉心算 欧拉筛
    bzoj3884: 上帝与集合的正确用法 扩展欧拉定理
  • 原文地址:https://www.cnblogs.com/hpuwangjunling/p/2407070.html
Copyright © 2011-2022 走看看