zoukankan      html  css  js  c++  java
  • Quicksum

     

    Quicksum

    时间限制:3000 ms  |  内存限制:65535 KB
    难度:2
     
    描述

    A checksum is an algorithm that scans a packet of data and returns a single number. The idea is that if the packet is changed, the checksum will also change, so checksums are often used for detecting transmission errors, validating document contents, and in many other situations where it is necessary to detect undesirable changes in data.

    For this problem, you will implement a checksum algorithm called Quicksum. A Quicksum packet allows only uppercase letters and spaces. It always begins and ends with an uppercase letter. Otherwise, spaces and letters can occur in any combination, including consecutive spaces.

    A Quicksum is the sum of the products of each character's position in the packet times the character's value. A space has a value of zero, while letters have a value equal to their position in the alphabet. So, A=1, B=2, etc., through Z=26. Here are example Quicksum calculations for the packets "ACM" and "MID CENTRAL":

    ACM: 1*1  + 2*3 + 3*13 = 46
    
    MID CENTRAL: 1*13 + 2*9 + 3*4 + 4*0 + 5*3 + 6*5 + 7*14 + 8*20 +
    9*18 + 10*1 + 11*12 = 650
     
    输入
    The input consists of one or more packets followed by a line containing only # that signals the end of the input. Each packet is on a line by itself, does not begin or end with a space, and contains from 1 to 300 characters.
    输出
    For each packet, output its Quicksum on a separate line in the output.
    样例输入
    ACM
    MID CENTRAL
    REGIONAL PROGRAMMING CONTEST
    ACN
    A C M
    ABC
    BBC
    #
    样例输出
    46
    650
    4690
    49
    75
    14
    15

    #include<iostream>
    #include<cstring>
    #include<cstdio>
    using namespace std;

    int main()
    {
      int str,i,k;
      char s[303];

      while(gets(s))
      {
        if(s[0]=='#')
      break;
     str=strlen(s);
     int sum=0;
     for(i=0;i<str;i++)
     {
       if(s[i]==' ') k=0; else k=(int)(s[i]-'@') ;
       sum+=(i+1)*k;
     }
     cout<<sum<<endl;
      }
      return 0;
    }

  • 相关阅读:
    基础命令
    RHEL7装机
    模拟项目
    配置NAT,PAT
    配置标准ACL,扩展ACL,命名ACL
    HSRP,STP配置
    三层交换配置及RIP动态路由
    vlan,trunk,DHCP,以太网通道
    ERRORS: MRBC.UserInfo.groups: (fields.E304) Reverse accessor for 'UserInfo.groups' clashes with reverse accessor for 'User.groups'. HINT: Add or change a related_name argument to the definition for '
    权限rbac(基于角色的访问控制)
  • 原文地址:https://www.cnblogs.com/hpuwangjunling/p/2407070.html
Copyright © 2011-2022 走看看