zoukankan      html  css  js  c++  java
  • UVA 10494-If We Were a Child Again(一流的塔尔苏斯)

    Problem C
    If We Were a Child Again

    Input: standard input
    Output: standard output

    Time Limit: 7 seconds

     

    “Oooooooooooooooh!

    If I could do the easy mathematics like my school days!!

    I can guarantee, that I’d not make any mistake this time!!”

    Says a smart university student!!

    But his teacher even smarter – “Ok! I’d assign you such projects in your software lab. Don’t be so sad.”

    “Really!!” - the students feels happy. And he feels so happy that he cannot see the smile in his teacher’s face.

     

    The Problem

     

    The first project for the poor student was to make a calculator that can just perform the basic arithmetic operations.

     

    But like many other university students he doesn’t like to do any project by himself. He just wants to collect programs from here and there. As you are a friend of him, he asks you to write the program. But, you are also intelligent enough to tackle this kind of people. You agreed to write only the (integer) division and mod (% in C/C++) operations for him.

     

    Input

    Input is a sequence of lines. Each line will contain an input number. One or more spaces. A sign (division or mod). Again spaces. And another input number. Both the input numbers are non-negative integer. The first one may be arbitrarily long. The second number n will be in the range (0 < n < 231).

     

     
    Output

    A line for each input, each containing an integer. See the sample input and output. Output should not contain any extra space.

     

     
     
    Sample Input

    110 / 100

    99 % 10

    2147483647 / 2147483647

    2147483646 % 2147483647

     

     

     

     

     
     
    Sample Output

    1

    9

    1

    2147483646

     


    第一次用java写,曾经从来没看过,今天看了一点主要的输入输出切了一道A+B后,直接来一道高精度的。1A得意,没有编译器,直接敲完就交,谁给我的勇气?。。。

    待会写一篇总结java里面的高精度大数的使用方法


    import java.io.*;
    
    import java.util.*;
    
    import java.math.*;
    import java.text.*;
    public class Main {
    
    		public static void main(String args[]) {
    
    		       Scanner in = new Scanner(System.in);
    
                           BigInteger a,b;char c;
                           while(in.hasNext()){
    		       a = in.nextBigInteger();
    
                           c=in.next().charAt(0);
    		       b = in.nextBigInteger();
    
    
    		       if(c=='/')
                           System.out.println(a.divide(b));
                           else
                            System.out.println(a.mod(b));
                           
                          }
    		
                   }
    
    }
    


    版权声明:本文博客原创文章。博客,未经同意,不得转载。

  • 相关阅读:
    深度优先和广度优先搜索
    宏定义
    C++11新特性之七——final/override控制
    __declspec的用法
    zedboard学习(1)OLED驱动显示图像
    python+NLTK 自然语言学习处理三:如何在nltk/matplotlib中的图片中显示中文
    流畅python学习笔记第十八章:使用asyncio编写服务器
    流畅python学习笔记第十八章:使用asyncio包处理并发(二)
    Django之博客系统:自定义认证
    Django之博客系统:用户注册和Profile
  • 原文地址:https://www.cnblogs.com/hrhguanli/p/4732457.html
Copyright © 2011-2022 走看看