zoukankan      html  css  js  c++  java
  • HDU 1171 Big Event in HDU

    Big Event in HDU

    Problem Description
    Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
    The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
     
    Input
    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
    A test case starting with a negative integer terminates input and this test case is not to be processed.
     
    Output
    For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
     
    Sample Input
    2 10 1 20 1 3 10 1 20 2 30 1 -1
     
    Sample Output
    20 10 40 40
     
    :此题用母函数解,注意最后求靠近中间值的结果的求法
    #include<iostream>
    using namespace std;
    #include<string.h>
    int c1[260000],c2[260000];
    int main()
    {
        int i,j,k,n;
        int va[52],num[52];
        int s;
        while(scanf("%d",&n)!=EOF&&n>0)
        {
            for(i=0;i<n;i++)
            {
             cin>>va[i]>>num[i];
            }
            memset(c1,0,sizeof(c1));
            memset(c2,0,sizeof(c2));
            for(i=0;i<=va[0]*num[0];i+=va[0])
            {
                c1[i]=1;
            }
            s=va[0]*num[0];
            for(i=1;i<n;i++)
            {
                for(j=0;j<=s;j++)
                 for(k=0;k<=va[i]*num[i];k+=va[i])
                 {
                     c2[j+k]+=c1[j];    
                 }
                 s+=va[i]*num[i];
                 for(j=0;j<=s;j++)//j
                 {
                     c1[j]=c2[j];
                     c2[j]=0;
                 }
            }
            
            for(i=s/2;i>=0;i--)
            {
                if(c1[i]!=0)
                {
                    printf("%d %d\n",s-i,i);
                    break;
                }
            }
            
        }
        
        return 0;
    }
  • 相关阅读:
    GeneXus笔记本—城市级联下拉
    GeneXus笔记本—获取当月的最后一天
    GeneXus笔记本——创建一个知识库 哈哈哈哈!
    GeneXus笔记本——入门篇
    Android Studio 学习笔记1.1 创建自己的第一个安卓项目并且打包APK
    初入Android Studio的我
    随笔
    在Azuer创建自己的Linux_VM
    获得自己电脑的SSH公匙
    数据库内连接、外连接以及左右连接的区别
  • 原文地址:https://www.cnblogs.com/hsqdboke/p/2456029.html
Copyright © 2011-2022 走看看