zoukankan      html  css  js  c++  java
  • Uva12230Crossing Rivers (数学期望)

    问题:

    You live in a village but work in another village. You decided to follow the straight path between your house (A) and the working place (B), but there are several rivers you need to cross. Assume B is to the right of A, and all the rivers lie between them. Fortunately, there is one “automatic” boat moving smoothly in each river. When you arrive the left bank of a river, just wait for the boat, then go with it. You’re so slim that carrying you does not change the speed of any boat.

    Days and days after, you came up with the following question: assume each boat is independently placed at random at time 0, what is the expected time to reach B from A? Your walking speed is always 1. To be more precise, for a river of length L, the distance of the boat (which could be regarded as a mathematical point) to the left bank at time 0 is uniformly chosen from interval [0, L], and the boat is equally like to be moving left or right, if it’s not precisely at the river bank.

    Input

    There will be at most 10 test cases. Each case begins with two integers n and D, where n (0 ≤ n ≤ 10) is the number of rivers between A and B, D (1 ≤ D ≤ 1000) is the distance from A to B. Each of the following n lines describes a river with 3 integers: p, L and v (0 ≤ p < D, 0 < L ≤ D, 1 ≤ v ≤ 100). p is the distance from A to the left bank of this river, L is the length of this river, v is the speed of the boat on this river. It is guaranteed that rivers lie between A and B, and they don’t overlap. The last test case is followed by n = D = 0, which should not be processed.

    Output

    For each test case, print the case number and the expected time, rounded to 3 digits after the decimal point. Print a blank line after the output of each test case.

    Sample Input

    1 1

    0 1 2

    0 1

    0 0

    Sample Output

    Case 1: 1.000

    Case 2: 1.000

    题目大意:

    有个人每天要去公司上班,每次会经过N条河,家和公司的距离为D,默认在陆地的速度为1,给出N条河的信息,包括起始坐标p,宽度L,以及船的速度v。船会往返在河的两岸,人到达河岸时,船的位置是随机的(往返中)。问说人达到公司所需要的期望时间。

    思路:

    过每条河最坏的情况是t=3*L/v; 即去的时候船刚刚走。

    过没条河最优的情况是t=L/v;    即去的时候船刚刚来。

    由于船是均匀发布的,符合线性性质,所以平均下来,过每条河的时间t=2*L/v。

    #include<cstdio>
    #include<cstdlib>
    #include<iostream>
    using namespace std;
    int main()
    {
        int n,D,dis,p,l,v,Case=0;
        double ans;
        while(~scanf("%d%d",&n,&D)){
            if(n==0&&D==0) return 0;
            dis=0;ans=0;
            while(n--){
                scanf("%d%d%d",&p,&l,&v);
                ans=ans+2.0*l/v;
                D-=l;
            }
            ans=ans+1.0*D;
            printf("Case %d: %.3lf
    
    ",++Case,ans);
        }
        return 0;
    }
  • 相关阅读:
    iOS提醒用户进入设置界面进行重新授权通知定位等功能
    JQ获得ul li 值导成字符串
    “真的”
    原来还有插入代码功能 我还挨个缩进呢 好白菜啊
    ffmpeg 批处理
    DW english
    CI 分页“第一页”问题
    Discuz论坛发帖统计
    我的产品被评为一个“玩具”
    根据css文件采集图片
  • 原文地址:https://www.cnblogs.com/hua-dong/p/8004195.html
Copyright © 2011-2022 走看看