zoukankan      html  css  js  c++  java
  • 简单并查集2hdu1213

    题目:https://vjudge.net/contest/182418#problem/C

    Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

    One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

    For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

    InputThe input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
    OutputFor each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
    Sample Input

    2
    5 3
    1 2
    2 3
    4 5
    
    5 1
    2 5

    Sample Output

    2
    4


    题意简单
    直接代码:“
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<cmath>
    #include<queue>
    #include<set>
    #include<algorithm>
    #include<map>
    #define maxn 10005
    using namespace std;
    int fa[maxn];
    void init(int n)
    {
        for(int i=1;i<=n;i++)
        {
            fa[i]=i;
    
        }
    }
    int find(int x)
    {
        if(fa[x]==x)return x;
        else{
            return fa[x]=find(fa[x]);
        }
    }
    void unite(int x,int y)
    {
        x=find(x);
        y=find(y);
        if(x==y)return ;
        if(x!=y)
        {
            fa[x]=y;
           // rank[y]+=rank[x];
        }
    }
    int main()
    {
        int T;
        cin>>T;
        while(T--)
        {
            int n,m,x,y;
            cin>>n>>m;
            init(n);
            while(m--)
            {
                cin>>x>>y;
                unite(x,y);
            }
            int ans=0;
            for(int j=1;j<=n;j++)
            {
                if(fa[j]==j)ans++;
            }
            cout<<ans<<endl;
        }
        return 0;
    }
  • 相关阅读:
    BestCoder17 1001.Chessboard(hdu 5100) 解题报告
    codeforces 485A.Factory 解题报告
    codeforces 485B Valuable Resources 解题报告
    BestCoder16 1002.Revenge of LIS II(hdu 5087) 解题报告
    codeforces 374A Inna and Pink Pony 解题报告
    codeforces 483B Friends and Presents 解题报告
    BestCoder15 1002.Instruction(hdu 5083) 解题报告
    codeforces 483C.Diverse Permutation 解题报告
    codeforces 483A. Counterexample 解题报告
    NSArray中地内存管理 理解
  • 原文地址:https://www.cnblogs.com/huangzzz/p/7993966.html
Copyright © 2011-2022 走看看