zoukankan      html  css  js  c++  java
  • HDU 2115

    I Love This Game

    Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 3593    Accepted Submission(s): 1231


    Problem Description
    Do you like playing basketball ? If you are , you may know the NBA Skills Challenge . It is the content of the basketball skills . It include several parts , such as passing , shooting , and so on. After completion of the content , the player who takes the shortest time will be the winner . Now give you their names and the time of finishing the competition , your task is to give out the rank of them ; please output their name and the rank, if they have the same time , the rank of them will be the same ,but you should output their names in lexicographic order.You may assume the names of the players are unique.

    Is it a very simple problem for you? Please accept it in ten minutes.
     
    Input
    This problem contains multiple test cases! Ease test case contain a n(1<=n<=10) shows the number of players,then n lines will be given. Each line will contain the name of player and the time(mm:ss) of their finish.The end of the input will be indicated by an integer value of zero.
     
    Output
    The output format is shown as sample below.
    Please output the rank of all players, the output format is shown as sample below;
    Output a blank line between two cases.
     
    Sample Input
    10 Iverson 17:19 Bryant 07:03 Nash 09:33 Wade 07:03 Davies 11:13 Carter 14:28 Jordan 29:34 James 20:48 Parker 24:49 Kidd 26:46 0
     
    Sample Output
    Case #1 Bryant 1 Wade 1 Nash 3 Davies 4 Carter 5 Iverson 6 James 7 Parker 8 Kidd 9 Jordan 10
    #include<stdio.h>
    #include<string.h>
    #include<stdlib.h>
    typedef struct DATA
    {
        char name[50];
        char time[10];
    }DATA;
    DATA ch[12];
    int cmp(const void *a,const void *b)
    {
        if(strcmp((*(DATA *)a).time,(*(DATA *)b).time))
            return strcmp((*(DATA *)a).time,(*(DATA *)b).time);
        return strcmp((*(DATA *)a).name,(*(DATA *)b).name);
    }        
    int main()
    {
        int num;
        int i,j,k;
         k=1;
        while(scanf("%d%*c",&num),num)
        {
            if(1!=k)
                printf("\n");//每组测试用例之间有空行 
            memset(ch,0,sizeof(ch));
            for(i=0;i<num;i++)//使用qsort最好从0开始 ,或者qsort(ch+1,……),不过没试过 
                scanf("%s %s",ch[i].name,ch[i].time);
            qsort(ch,num,sizeof(DATA),cmp);
            printf("Case #%d\n",k);
            printf("%s 1\n",ch[0].name);
            k++;
            for(i=1,j=0;i<num;i++)
            {   
                if(strcmp(ch[i].time,ch[i-1].time)==0)
                    j++;
                else 
                    j=0;
                printf("%s %d\n",ch[i].name,i+1-j);
            }
            //printf("\n");//不能加在这,否则最后一行会多一行空行 
        }
        return 0;
    }
                
            
            
            
        
    
  • 相关阅读:
    手动安装ceph集群
    openstack端口禁用安全规则
    debian10桌面美化
    debian10 制作动态扩容根分区镜像
    CentOS7制作动态扩容根分区镜像
    EFKLK日志收集工具栈
    ceph rbd(csi) 对接 kubernetes sc
    secureCRT 814配色方案
    python function
    Linux操作篇之LNMP(一)
  • 原文地址:https://www.cnblogs.com/hxsyl/p/2612373.html
Copyright © 2011-2022 走看看