zoukankan      html  css  js  c++  java
  • POJ 1012

    Joseph
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 40823   Accepted: 15337

    Description

    The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

    Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.

    Input

    The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

    Output

    The output file will consist of separate lines containing m corresponding to k in the input file.

    Sample Input

    3
    4
    0
    

    Sample Output

    5
    30
    /*
    因为只有14个测试数据,所以我可大胆猜想这是怕超过int,
    既然接近INT_MAX,那么试探m的值很可能超时
    */
    //实在没办法的时候,用TLE的程序打表 
    #include<stdio.h>
    #include<string.h>
    int vis[14];
    bool is_true(int k,int m)
    {
    	int n,i,s;
    	n=2*k;
        s=0;
    	for(i=0;i<k;i++)
    	{
    		s=(s+m-1)%(n-i);
    		if(s<k) return 0;//遇到前k轮中有小于k的直接返回0
    	}
    	return 1;
    }
    int main()
    {
    	int i,k,n;
    	for(k=1;k<=14;k++)
    	{
    		i=k+1;
            while(1)
    		{
    			if(is_true(k,i))
    			{
    				vis[k]=i;
    				break;
    			}
    			else if(is_true(k,i+1))
    			{
    				vis[k]=i+1;
    				break;
    			}
    			i+=k+1;
    		}
    	}
    	while(scanf("%d",&n),n)
    	{
    		printf("%d\n",vis[n]);
    	}
    	return 0;
    }
    
  • 相关阅读:
    Mac下写博客工具ecto相关资料
    重装MacOS
    Mac下写博客工具MarsEdit相关资料
    Mac下安装最新版本的Graphviz
    什么是回归分析?
    Mac 配置Charles抓https的包
    Android sdk tool android 命令参数
    判断某个端口被那个进程占用
    [置顶] 微创新时代个人崛起的方法
    xml获取配置DataTable
  • 原文地址:https://www.cnblogs.com/hxsyl/p/2617699.html
Copyright © 2011-2022 走看看