zoukankan      html  css  js  c++  java
  • YTU 2602: 熟悉题型——类设计( 矩形类定义【C++】)

    2602: 熟悉题型——类设计( 矩形类定义【C++】)

    时间限制: 1 Sec  内存限制: 128 MB
    提交: 183  解决: 119

    题目描述

    定义一个矩形类,数据成员包括左下角和右上角坐标,定义的成员函数包括必要的构造函数、输入坐标的函数,以及计算并输出矩形面积的函数。要求使用提示中给出的测试函数并不得改动。

    输入

    四个数,分别表示矩形左下角和右上角顶点的坐标,如输入3.7 0.4 6.5 4.9,代表左下角坐标为(3.7, 0.4),右上角坐标为(6.5, 4.9)。

    请根据给出的主函数,完成矩形类设计。

    输出

    输出一共有3行(请参考提示(hint)中的main函数):
    第一行:由输入的坐标确定的矩形对象p1的面积
    第二行:由对象复制得到的矩形对象p2的面积
    第三行:直接初始化得到的矩形对象p3的面积

    样例输入

    3.7 0.4 6.5 4.9

    样例输出

    12.6
    12.6
    10
    

    提示

    int main()



    {



    Rectangle p1;



    p1.input();



    p1.output();



    Rectangle p2(p1);



    p2.output();



    Rectangle p3(1,1,6,3);



    p3.output();



    return 0;



    }

    迷失在幽谷中的鸟儿,独自飞翔在这偌大的天地间,却不知自己该飞往何方……

    #include <iostream>
    #include <cmath>
    using namespace std;
    class Rectangle
    {
    public:
        Rectangle (double a=0,double b=0,double c=0,double d=0);
        Rectangle (Rectangle &p);
        void input();
        void output();
    private:
        double x1,y1,x2,y2;
    
    };
    Rectangle::Rectangle(double a,double b,double c,double d)
    {
        x1=a,y1=b,x2=c,y2=d;
    }
    void Rectangle::input()
    {
        double a,b,c,d;
        cin>>a>>b>>c>>d;
        x1=a,y1=b,x2=c,y2=d;
    }
    Rectangle::Rectangle(Rectangle &p)
    {
        x1=p.x1,y1=p.y1,x2=p.x2,y2=p.y2;
    }
    void Rectangle::output()
    {
        cout<<fabs((x2-x1)*(y2-y1))<<endl;
    }
    int main()
    {
        Rectangle p1;
        p1.input();
        p1.output();
        Rectangle p2(p1);
        p2.output();
        Rectangle p3(1,1,6,3);
        p3.output();
        return 0;
    }
    

  • 相关阅读:
    Roads in the North
    Labyrinth
    英语写作(二)
    语法长难句笔记
    英语写作(一)
    MySQL笔记(二)
    MySQL笔记(一)
    Mybatis简单使用与配置
    Mybatis映射文件
    什么是serializable接口?
  • 原文地址:https://www.cnblogs.com/im0qianqian/p/5989533.html
Copyright © 2011-2022 走看看