zoukankan      html  css  js  c++  java
  • POJ 1477:Box of Bricks

    Box of Bricks
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 19949   Accepted: 8029

    Description

    Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. "Look, I've built a wall!", he tells his older sister Alice. "Nah, you should make all stacks the same height. Then you would have a real wall.", she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help? 


    Input

    The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1 <= n <= 50 and 1 <= hi <= 100. 

    The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height. 

    The input is terminated by a set starting with n = 0. This set should not be processed. 

    Output

    For each set, first print the number of the set, as shown in the sample output. Then print the line "The minimum number of moves is k.", where k is the minimum number of bricks that have to be moved in order to make all the stacks the same height. 

    Output a blank line after each set.

    Sample Input

    6
    5 2 4 1 7 5
    0

    Sample Output

    Set #1
    The minimum number of moves is 5.
    

    Source

    Southwestern European Regional Contest 1997

    你  离  开  了  ,  我  的  世  界  里  只  剩  下  雨  。  。  。

    #include <stdio.h>
    int main()
    {
        int n,i,s,aver,a[51],num,j=0;
        while(~scanf("%d", &n))
        {
            if(n == 0) break;
            j++,s = 0,num = 0;
            for(i = 0; i < n; i++)
            {
                scanf("%d", &a[i]);
                s+=a[i];
            }
            aver= s/n;
            for(i = 0; i < n; i++)
                if(a[i] > aver)
                    num = num + a[i] - aver;
            printf("Set #%d
    The minimum number of moves is %d.
    
    ", j, num);
        }
        return 0;
    }


  • 相关阅读:
    SAX解析xml,小实例
    Pull解析xml,小实例
    TCP通信小实例
    android 获取手机信息
    mysql创建用户与授权
    java执行SQL脚本文件
    IOUtils.readFully()的使用
    下载工具类
    vue element ui 父组件控制子组件dialog的显隐
    springboot-mybatis配置多数据源
  • 原文地址:https://www.cnblogs.com/im0qianqian/p/5989589.html
Copyright © 2011-2022 走看看