zoukankan      html  css  js  c++  java
  • HDU-2612 Find a way

    Problem Description
    Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
    Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.
    Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.
     
    Input
    The input contains multiple test cases.
    Each test case include, first two integers n, m. (2<=n,m<=200).
    Next n lines, each line included m character.
    ‘Y’ express yifenfei initial position.
    ‘M’    express Merceki initial position.
    ‘#’ forbid road;
    ‘.’ Road.
    ‘@’ KCF
     
    Output
    For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.
     
    Sample Input
    4 4
    Y.#@
    ....
    .#..
    @..M
    4 4
    Y.#@
    ....
    .#..
    @#.M
    5 5
    Y..@.
    .#...
    .#...
    @..M.
    #...#
     
    Sample Output
    66 88 66

    思路:
    A题的快感胜于一切不解释
    题目不错,让我重新认识了bfs的功效。其实这个题思路倒是很容易,就是遍历下两个人到每个‘@’的距离,存起来然后看看哪个最短就行,关键的问题在于数据结构,即数据的存储和操作方式。
    一开始我的想法是用map,即将每个点到行走人的距离映射到该点的坐标上,但是我卡在了不会求行走距离,之前那会儿总是想用dfs来求,做的题目还不够多= =后来上网看了题解,发现使用bfs以Y或M为初始点遍历图中所有点到出发点的距离,关键的公式就是
    dis[dx][dy] = dis[temp.x][temp.y]+1;
    

    当时第一次看这到这个公式的时候反应是DP(我真是好久没做DP了)

    后来发现原来这就是bfs的精髓


    #include <iostream>
    #include <cstring>
    #include <queue>
    #define INF 0x7fffffff
    using namespace std;
    
    int n,m;
    char G[207][207];
    int dir[4][2] = {{-1,0},{0,-1},{0,1},{1,0}};
    struct pos{
    	int x,y;
    };
    int dis_1[207][207];
    int dis_2[207][207];
    
    bool judge(int x,int y)
    {
    	if(x>=1&& x<=n && y>=1 && y<=m && G[x][y]!='#')
    		return true;
    	else return false;
    }
    
    void bfs(int a,int b,int vis[207][207],int dis[207][207])
    {
    	vis[a][b] = 1;
    	queue<pos> q;
    	pos s;
    	s.x = a;
    	s.y = b;
    	q.push(s);
    	while(!q.empty())
    	{
    		pos temp = q.front();
    		q.pop();
    		for(int i = 0;i <= 3;i++)
    		{
    			int dx = temp.x+dir[i][0];
    			int dy = temp.y+dir[i][1];
    			if(!vis[dx][dy] && judge(dx,dy)) {
    				vis[dx][dy] = 1;
    				dis[dx][dy] = dis[temp.x][temp.y]+1;
    				pos n;
    				n.x = dx;
    				n.y = dy;
    				q.push(n);
    			}
    		}
    	}
    }
    
    int main()
    {
    	while(cin>>n>>m)
    	{
    		int x1,y1,x2,y2;
    		int vis_1[207][207];
    		int vis_2[207][207];
    		for(int i = 1;i <= n;i++)
    			cin>>G[i]+1;
    		for(int i = 1;i <= n;i++)
    			for(int j = 1;j <= m;j++) {
    				if(G[i][j] == 'Y')
    				{
    					x1 = i;
    					y1 = j;
    				}
    				if(G[i][j] == 'M')
    				{
    					x2 = i;
    					y2 = j;
    				}
    			}
    		memset(dis_1,0,sizeof(dis_1));
    		memset(dis_2,0,sizeof(dis_2));
    		memset(vis_1,0,sizeof(vis_1));
    		memset(vis_2,0,sizeof(vis_2));
    		bfs(x1,y1,vis_1,dis_1);	
    		bfs(x2,y2,vis_2,dis_2);
    		int ans = INF;
    		for(int i = 1;i <= n;i++)
    			for(int j = 1;j <= m;j++)
    				if(G[i][j] == '@' && vis_1[i][j] && vis_2[i][j])
    					ans = dis_1[i][j]+dis_2[i][j]<ans?dis_1[i][j]+dis_2[i][j]:ans;
    		cout<<ans*11<<endl;
    	}
    	return 0;
    }
    
  • 相关阅读:
    CSS BEM 命名规范简介
    React 端的编程范式
    在React应用程序中用RegEx测试密码强度
    React 中获取数据的 3 种方法及它们的优缺点
    vue props传值常见问题
    如何理解vue中的v-model?
    利用jQuery not()方法选取除某个元素外的所有元素
    初识Nest.js
    react-绑定this并传参的三种方式
    Angular怎么防御xss攻击?
  • 原文地址:https://www.cnblogs.com/immortal-worm/p/5133046.html
Copyright © 2011-2022 走看看