zoukankan      html  css  js  c++  java
  • Tree

    Tree

    描述

    Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.  This is an example of one of her creations: 

                                                    D
    
                                                  / 
    
                                                 /   
    
                                                B     E
    
                                               /      
    
                                              /        
    
                                             A     C     G
    
                                                        /
    
                                                       /
    
                                                      F

    To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.  She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 
    Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.  However, doing the reconstruction by hand, soon turned out to be tedious.  So now she asks you to write a program that does the job for her! 

     
    输入
    The input will contain one or more test cases.  Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)  Input is terminated by end of file.
    输出
    For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).
    样例输入
    DBACEGF ABCDEFG
    BCAD CBAD
    样例输出
    ACBFGED
    CDAB

     
    #include <iostream>
    #include <string>
    
    using namespace std;
    string pos;
    void convert(string pre,string in)
    {
        
        
        if(in.size()==1)
            pos+=in;
        else
        {
            int k=in.find(pre.substr(0,1));
    
            if(k>0)
                convert(pre.substr(1,k),in.substr(0,k));
            if(k<in.size()-1)
                convert(pre.substr(k+1,pre.size()-k-1),in.substr(k+1,in.size()-k-1));
    
            pos+=in[k];
        }
    
    
    }
    
    int main()
    {
        string str_pre;
        string str_in;
        
        while(cin>>str_pre>>str_in && !cin.eof())
        {
    
        convert(str_pre,str_in);
    
        cout<<pos<<endl;
        pos = "";
        
        }
    
        return 0;
    }        
  • 相关阅读:
    使用WCF实现消息推送
    T31P电子秤数据读取
    持续性任务代码的一些测试
    XP+Android手机DIY家庭视频点播系统-历时3周全力打造吊丝的幸福生活
    Android 上传文件到XP
    Android ListView的一个坑,你可掉进去过?
    无脑无负担网站架构-- Application Request Route的一些应用
    Android 一些注意
    懒人的ERP开发框架--2B&苦B程序员专用
    PHP Token(令牌)设计应用
  • 原文地址:https://www.cnblogs.com/imwtr/p/4069533.html
Copyright © 2011-2022 走看看