zoukankan      html  css  js  c++  java
  • HDU 1022 Train Problem I

    Train Problem I

    http://acm.hdu.edu.cn/showproblem.php?pid=1022

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 12861    Accepted Submission(s): 4705

    Problem Description
    As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
     
    Input
    The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
     
    Output
    The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
     
    Sample Input
     
    3 123 321
    3 123 312
     
    Sample Output
     
    Yes.
    in
    in
    in
    out
    out
    out
    FINISH
    No.
    FINISH
    Hint
    Hint
    For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".
     
    Author
    Ignatius.L
     
     
     
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<queue>
    #include<algorithm>
    #include<vector>
    #include<stack>
    
    using namespace std;
    
    int n;
    char str1[20],str2[20];
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int res[40];
        stack<int> st;
        while(~scanf("%d%s%s",&n,str1,str2)){
            while(!st.empty())
                st.pop();
            int cnt=1,j=0,tag=1;
            res[0]=1;
            st.push(str1[0]);
            for(int i=0;str2[i]!='\0';i++){
                while(st.empty() || (!st.empty() && st.top()!=str2[i])){
                    res[cnt++]=1;
                    tag++;
                    j++;
                    st.push(str1[j]);
                }
                if(!st.empty() && st.top()==str2[i]){
                    res[cnt++]=2;
                    st.pop();
                }
            }
            //printf("cnt=%d  tag=%d\n",cnt,tag);
            if(cnt==2*n && tag==n){
                puts("Yes.");
                for(int i=0;i<cnt;i++)
                    switch(res[i]){
                        case 1:puts("in");break;
                        case 2:puts("out");break;
                    }
                puts("FINISH");
            }else
                printf("No.\nFINISH\n");
        }
        return 0;
    }
  • 相关阅读:
    vue 重定向
    vue 通过插槽分发内容
    vue 表单输入绑定 checkbox
    jq enter键发送
    vue footer点击变色
    vue computed和methods 计算属性和侦听器
    实时监听input输入情况
    关于Input输入框蓝色外框的操作
    鼠标悬浮指针变手
    鼠标悬浮样式
  • 原文地址:https://www.cnblogs.com/jackge/p/2837978.html
Copyright © 2011-2022 走看看