zoukankan      html  css  js  c++  java
  • POJ 1195 Mobile phones

    Mobile phones
    Time Limit: 5000MS   Memory Limit: 65536K
    Total Submissions: 11696   Accepted: 5369

    Description

    Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix.
    Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area.

    Input

    The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table.
    The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3.
    Table size: 1 * 1 <= S * S <= 1024 * 1024
    Cell value V at any time: 0 <= V <= 32767 Update amount: -32768 <= A <= 32767 No of instructions in input: 3 <= U <= 60002
    Maximum number of phones in the whole table: M= 2^30

    Output

    Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

    Sample Input

    0 4
    1 1 2 3
    2 0 0 2 2 
    1 1 1 2
    1 1 2 -1
    2 1 1 2 3 
    3
    

    Sample Output

    3
    4

    Source

     

    2、解题思路:题意,给定n*n矩阵,和几种在线操作,包括对某一点(x,y)值修改,查询一个矩形(x1,y1,x2,y2)的元素和。步骤,(1)树状数组的经典应用;(2)面积处理过程中,面积=Sum(R,T)-Sum(R,B-1)-Sum(L-1,T)+Sum(L-1,B-1)。

    3、注意事项:注意貌似除了树状数组这种方法,其他的方法都TLE,面积处理时候,记得加上减去两次的部分Sum(L-1,B-1)。

    #include<iostream>
    #include<cstdio>
    
    using namespace std;
    
    int N,c[1050][1050];
    
    int lowbit(int x){
        return x&(-x);
    }
    
    int Sum(int x,int y){
        int sum=0;
        for(int i=x;i>0;i-=lowbit(i))
            for(int j=y;j>0;j-=lowbit(j))
                sum+=c[i][j];
        return sum;
    }
    
    void update(int x,int y,int val){
        for(int i=x;i<=N;i+=lowbit(i))
            for(int j=y;j<=N;j+=lowbit(j))
                c[i][j]+=val;
    }
    
    int main(){
        int op;
        int x,y,a;
        int l,b,r,t;
        scanf("%d%d",&op,&N);
        while(scanf("%d",&op) && op!=3){
            if(op==1){
                scanf("%d%d%d",&x,&y,&a);
                update(x+1,y+1,a);
            }else if(op==2){
                scanf("%d%d%d%d",&l,&b,&r,&t);
                int ans=Sum(r+1,t+1)-Sum(r+1,b)-Sum(l,t+1)+Sum(l,b);
                printf("%d\n",ans);
            }
        }
        return 0;
    }
  • 相关阅读:
    AngularJS中的Provider们:Service和Factory等的区别
    解决Eclipse建立Maven项目后无法建立src/main/java资源文件夹的办法
    关于EL表达式不起作用的问题
    Tomcat+Nginx 负载均衡配置,Tomcat+Nginx集群,Tomcat集群
    Java WebService 简单实例
    火狐浏览器中表单内容在表单刷新时候不重置表单信息
    ie文本框内容不居中问题
    javascript call和apply方法
    javascript的词法作用域
    C++提高编程 deque容器
  • 原文地址:https://www.cnblogs.com/jackge/p/2844003.html
Copyright © 2011-2022 走看看