zoukankan      html  css  js  c++  java
  • HDU 1358 Period (KMP)

    Period

    http://acm.hdu.edu.cn/showproblem.php?pid=1358

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 1537    Accepted Submission(s): 742

    Problem Description
    For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
     
    Input
    The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
     
    Output
    For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
     
    Sample Input
     
    3
    aaa
    12
    aabaabaabaab
    0
     
    Sample Output
     
    Test case #1
    2 2
    3 3
     
    Test case #2
    2 2
    6 2
    9 3
    12 4
     
     
    Recommend
    JGShining
     
     
     
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    
    using namespace std;
    
    const int N=1000010;
    
    char str[N];
    int next[N];
    
    void getnext(int len){
        int i=0,j=-1;
        next[0]=-1;
        while(i<len){
            if(j==-1 || str[i]==str[j]){
                i++;j++;
                next[i]=j;
            }else
                j=next[j];
        }
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int len,cases=0;
        while(~scanf("%d",&len) && len){
            scanf("%s",str);
            getnext(len);
            printf("Test case #%d\n",++cases);
            for(int i=2;i<=len;i++){
                int tmp=i-next[i];  //循环节长度
                if(i%tmp==0 && i/tmp>1)
                    printf("%d %d\n",i,i/tmp);      //output each prefix with length i,and a period i/tmp
            }
            printf("\n");
        }
        return 0;
    }
  • 相关阅读:
    基于脚本的nodemanager管理器
    SSH 等效性问题 总提示输入密码问题
    增量检查点【概念】
    【ORA错误大全】 ORA-19527
    DataGuard 配置须知
    rhel5.4+oracle 10g rac
    microg,google新推的一个计划
    [转]Android ListView 与 RecyclerView 对比浅析—缓存机制
    android studio的Beta, Canary, Dev, Stable四种Channel版本介绍、分析与选择
    android studio增量更新
  • 原文地址:https://www.cnblogs.com/jackge/p/2846127.html
Copyright © 2011-2022 走看看