zoukankan      html  css  js  c++  java
  • HDU 2795 Billboard

    Billboard

    http://acm.hdu.edu.cn/showproblem.php?pid=2795

    Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 5633    Accepted Submission(s): 2580

    Problem Description
    At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.
    On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.
    Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.
    When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.
    If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).
    Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
     
    Input
     
    There are multiple cases (no more than 40 cases).
    The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.
    Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
     
    Output
     
    For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
     
    Sample Input
     
    3 5 5
    2
    4
    3
    3
    3
     
    Sample Output
     
    1
    2
    1
    3
    -1
     
    Author
    hhanger@zju
     
    Source
     
    Recommend
    lcy
     
     
     
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    const int N=200010;
    
    #define L(rt) (rt<<1)
    #define R(rt) (rt<<1|1)
    
    struct Tree{
        int l,r;
        int len;    //该行长度(剩余长度,开始为w)
    }tree[N<<2];
    
    int h,w,n;
    
    void PushUp(int rt){    //更新父结点的最大剩余长度
        tree[rt].len=max(tree[L(rt)].len,tree[R(rt)].len);
    }
    
    void build(int L,int R,int rt){
        tree[rt].l=L;
        tree[rt].r=R;
        tree[rt].len=w;
        if(tree[rt].l==tree[rt].r)
            return;
        int mid=(L+R)>>1;
        build(L,mid,L(rt));
        build(mid+1,R,R(rt));
        PushUp(rt);
    }
    
    int query(int val,int rt){
        if(tree[rt].l==tree[rt].r){     //找到适合的叶结点,并更新其剩余长度,输出其id号
            tree[rt].len-=val;
            return tree[rt].l;
        }
        int ans;
        if(val<=tree[L(rt)].len)    //当左右子树都同时满足的情况下,优先选择左子树,若发现len不满足则停止搜索这棵子树
            ans=query(val,L(rt));
        else if(val<=tree[R(rt)].len)
            ans=query(val,R(rt));
        PushUp(rt);
        return ans;
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        while(~scanf("%d%d%d",&h,&w,&n)){
            if(h>=n)    //n张海报最多张贴n行,多出无用
                h=n;
            build(1,h,1);
            int x;
            while(n--){
                scanf("%d",&x);
                if(tree[1].len>=x)  //1号结点是所有结点的父结点,若广告长度大于它的剩余长度,则无解
                    printf("%d\n",query(x,1));
                else
                    printf("-1\n");
            }
        }
        return 0;
    }
  • 相关阅读:
    史上最简单的 SpringCloud 教程 | 第一篇: 服务的注册与发现(Eureka)
    漫谈《大型网站技术架构》
    如何使用MongoDB+Springboot实现分布式ID?
    IOS UIView 01-View开始深入 绘制像素到屏幕上
    IOS 多线程04-GCD详解 底层并发 API
    IOS 多线程05-OperationQueue 、GCD详解
    IOS 多线程02-pthread 、 NSThread 、GCD 、NSOperationQueue、NSRunLoop
    IOS 公共类-数字处理
    React Native02-开始运行 Android篇
    React Native01-开始 Windows环境安装配置篇
  • 原文地址:https://www.cnblogs.com/jackge/p/2847185.html
Copyright © 2011-2022 走看看