zoukankan      html  css  js  c++  java
  • HDU Big Event in HDU

    Big Event in HDU

    Time Limit: 1000/5000 MS (Java/Others)     Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1    Accepted Submission(s): 1
    Problem Description
    Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
    The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
     
    Input
    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
    A test case starting with a negative integer terminates input and this test case is not to be processed.
     
    Output
    For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
     
    SampleInput
    2
    10 1
    20 1
    3
    10 1 
    20 2
    30 1
    -1
     
    SampleOutput
    20 10
    40 40
     
    Author
    lcy
     
     
     
     
    #include<stdio.h>
    #include<string.h>
    
    int n;
    int dp[250010],num[60],val[60];
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        while(scanf("%d",&n)){
            if(n<=0)
                break;
            int i,j,k;
            int sum=0;
            for(i=0;i<n;i++){
                scanf("%d%d",&val[i],&num[i]);
                sum+=val[i]*num[i];
            }
            memset(dp,0,sizeof(dp));
            dp[0]=1;
            for(i=0;i<n;i++)
                for(k=0;k<num[i];k++)
                    for(j=sum/2;j>=val[i];j--)
                        if(dp[j-val[i]])
                            dp[j]=1;
            for(i=sum/2;i>=0;i--)
                if(dp[i]){
                    printf("%d %d\n",sum-i,i);
                    break;
                }
        }
        return 0;
    }
     
  • 相关阅读:
    将Infopath转成PDF
    调用MOSS API取document时出现out of memeory错误
    jquery dialog中mvc客户端验证无效
    Windows Service开发点滴20130622
    CentOS
    nginx
    VIM
    nodejs weixin 笔记
    nodejs mysql
    nodejs 笔记
  • 原文地址:https://www.cnblogs.com/jackge/p/2964363.html
Copyright © 2011-2022 走看看