zoukankan      html  css  js  c++  java
  • HDU 1856 More is better

    More is better

    Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others) Total Submission(s): 8214    Accepted Submission(s): 3069

    Problem Description
    Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.
    Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
     
    Input
    The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
     
    Output
    The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
     
    Sample Input
    4
    1 2
    3 4
    5 6
    1 6
    4
    1 2
    3 4
    5 6
    7 8
     
    Sample Output
    4
    2
     
    Hint
     
    A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
     
    Author
    lxlcrystal@TJU
     
    Source
     
    Recommend
    lcy
     
     
     
     
    #include<stdio.h>
    
    const int maxn=10000010;
    
    int n,ans,father[maxn],rank[maxn];
    
    int max(int a,int b){
        return a>b?a:b;
    }
    
    void makeSet(int n){
        for(int i=1;i<=n;i++){
            father[i]=i;
            rank[i]=1;
        }
    }
    
    int findSet(int x){
        if(x!=father[x]){
            father[x]=findSet(father[x]);
        }
        return father[x];
    }
    
    void Union(int a,int b){
        int x=findSet(a);
        int y=findSet(b);
        if(x==y)
            return ;
        if(rank[x]<=rank[y]){
            father[x]=y;
            rank[y]+=rank[x];
            ans=max(ans,rank[y]);
        }else{
            father[y]=x;
            rank[x]+=rank[y];
            ans=max(ans,rank[x]);
        }
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int a,b;
        while(scanf("%d",&n)!=EOF){
            if(n==0){
                printf("1\n");
                continue;
            }
            makeSet(maxn);
            ans=1;
            for(int i=0;i<n;i++){
                scanf("%d%d",&a,&b);
                Union(a,b);
            }
            printf("%d\n",ans);
        }
        return 0;
    }
  • 相关阅读:
    数组的处理
    bootstrap 列的排序
    bootstrap 偏移
    mysql数据库创建、删除数据库
    Spring 加载配置文件的方式
    MyBatis DAO层传递参数到mapping.xml 几种方式
    Python 正则表达式
    Python 之定时器
    Python学习
    获取鼠标经过位置的X、Y坐标
  • 原文地址:https://www.cnblogs.com/jackge/p/2966216.html
Copyright © 2011-2022 走看看