zoukankan      html  css  js  c++  java
  • HDU 1078 FatMouse and Cheese (DFS+DP)

    FatMouse and Cheese

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 3194    Accepted Submission(s): 1253

    Problem Description
    FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.
    FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.
    Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 
     
    Input
    There are several test cases. Each test case consists of 
    a line containing two integers between 1 and 100: n and k  n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.  The input ends with a pair of -1's. 
     
    Output
    For each test case output in a line the single integer giving the number of blocks of cheese collected. 
     
    Sample Input
    3 1
    1 2 5
    10 11 6
    12 12 7
    -1 -1
     
    Sample Output
    37
     
    Source
     
     
     
    #include<stdio.h>
    #include<string.h>
    
    int map[120][120],dp[120][120];
    int n,k;
    
    int dir[4][2]={{1,0},{0,1},{-1,0},{0,-1}};
    
    int DFS(int x,int y){
        int tmp,max=0;
        if(dp[x][y])
            return dp[x][y];
        for(int i=0;i<4;i++)
            for(int j=1;j<=k;j++){
                int tx=x+dir[i][0]*j;
                int ty=y+dir[i][1]*j;
                if(tx>=0 && tx<n && ty>=0 && ty<n && map[tx][ty]>map[x][y]){
                    tmp=DFS(tx,ty);
                    if(tmp>max)
                        max=tmp;
                }
            }
        dp[x][y]=max+map[x][y];
        return dp[x][y];
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        while(scanf("%d%d",&n,&k)){
            if(n==-1 && k==-1)
                break;
            for(int i=0;i<n;i++)
                for(int j=0;j<n;j++)
                    scanf("%d",&map[i][j]);
            memset(dp,0,sizeof(dp));
            DFS(0,0);
            printf("%d\n",dp[0][0]);
        }
        return 0;
    }
  • 相关阅读:
    再度学习MYSQL-----(1.基础)
    GIL解释器锁(进程与线程的应用场景)
    Django学习三有关表的创建查询类
    Django学习二模板
    Django学习一
    JQuery学习一
    前端基础学习之css二
    前端基础之css一
    mysql----单表多表查询
    MySQL-----表操作
  • 原文地址:https://www.cnblogs.com/jackge/p/2982875.html
Copyright © 2011-2022 走看看