zoukankan      html  css  js  c++  java
  • HDU 1224 Free DIY Tour

    Free DIY Tour

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 2218    Accepted Submission(s): 717

    Problem Description
    Weiwei is a software engineer of ShiningSoft. He has just excellently fulfilled a software project with his fellow workers. His boss is so satisfied with their job that he decide to provide them a free tour around the world. It's a good chance to relax themselves. To most of them, it's the first time to go abroad so they decide to make a collective tour.
    The tour company shows them a new kind of tour circuit - DIY circuit. Each circuit contains some cities which can be selected by tourists themselves. According to the company's statistic, each city has its own interesting point. For instance, Paris has its interesting point of 90, New York has its interesting point of 70, ect. Not any two cities in the world have straight flight so the tour company provide a map to tell its tourists whether they can got a straight flight between any two cities on the map. In order to fly back, the company has made it impossible to make a circle-flight on the half way, using the cities on the map. That is, they marked each city on the map with one number, a city with higher number has no straight flight to a city with lower number. 
    Note: Weiwei always starts from Hangzhou(in this problem, we assume Hangzhou is always the first city and also the last city, so we mark Hangzhou both 1 andN+1), and its interesting point is always 0.
    Now as the leader of the team, Weiwei wants to make a tour as interesting as possible. If you were Weiwei, how did you DIY it?
     
    Input
    The input will contain several cases. The first line is an integer T which suggests the number of cases. Then T cases follows. Each case will begin with an integer N(2 ≤ N ≤ 100) which is the number of cities on the map. Then N integers follows, representing the interesting point list of the cities. And then it is an integer M followed by M pairs of integers [Ai, Bi] (1 ≤ i ≤ M). Each pair of [Ai, Bi] indicates that a straight flight is available from City Ai to City Bi.
     
    Output
    For each case, your task is to output the maximal summation of interesting points Weiwei and his fellow workers can get through optimal DIYing and the optimal circuit. The format is as the sample. You may assume that there is only one optimal circuit. 
    Output a blank line between two cases.
     
    Sample Input
    2
    3
    0 70 90
    4
    1 2
    1 3
    2 4
    3 4
    3
    0 90 70
    4
    1 2
    1 3
    2 4
    3 4
     
    Sample Output
    CASE 1#
    points : 90
    circuit : 1->3->1
     
    CASE 2#
    points : 90
    circuit : 1->2->1
     
    Author
    JGShining(极光炫影)
     
    Source
     
    Recommend
    Ignatius.L
     
     
     
    #include<stdio.h>
    #include<string.h>
    
    int map[120][120],visited[120];
    int ans[120],dp[120],pre[120];
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int t,n,m,max;
        int cases=0;
        scanf("%d",&t);
        while(t--){
            scanf("%d",&n);
            int i,j,k;
            for(i=1;i<=n;i++)
                scanf("%d",&dp[i]);
            memset(visited,0,sizeof(visited));
            dp[n+1]=0;
            visited[1]=1;
            scanf("%d",&m);
            memset(map,0,sizeof(map));
            int a,b;
            for(i=0;i<m;i++){
                scanf("%d%d",&a,&b);
                map[a][b]=1;
            }
            for(i=1;i<=n+1;i++){
                max=-1000000;
                k=0;
                for(j=1;j<i;j++)
                    if(visited[j] && map[j][i] && dp[j]>max){
                        max=dp[j];
                        k=j;
                    }
                if(k!=0){
                    visited[i]=1;
                    dp[i]+=max;
                    pre[i]=k;
                }
            }
            printf("CASE %d#\npoints : %d\ncircuit : 1->",++cases,dp[n+1]);
            i=n+1;j=0;
            while(i!=1){
                ans[j++]=i;
                i=pre[i];
            }
            for(k=j-1;k>0;k--)
                printf("%d->",ans[k]);
            printf("1\n");
            if(t!=0)
                printf("\n");
        }
        return 0;
    }
  • 相关阅读:
    简单读取winfrom资源文件
    string.Format对C#字符串格式化
    如何在SQL中使用循环结构
    Linq to SQL 多条件动态组合查询(实战篇)
    提问的艺术
    XtraGrid 单元格加边框颜色
    凭证控件制作
    C# double 四舍五入
    自定义光标样式
    触发窗体事件(例如按Esc关闭窗体)
  • 原文地址:https://www.cnblogs.com/jackge/p/2983897.html
Copyright © 2011-2022 走看看