zoukankan      html  css  js  c++  java
  • POJ 1861 Network (Kruskal)

    Network
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 11372   Accepted: 4337   Special Judge

    Description

    Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the company, they can be connected to each other using cables. Since each worker of the company must have access to the whole network, each hub must be accessible by cables from any other hub (with possibly some intermediate hubs). 
    Since cables of different types are available and shorter ones are cheaper, it is necessary to make such a plan of hub connection, that the maximum length of a single cable is minimal. There is another problem — not each hub can be connected to any other one because of compatibility problems and building geometry limitations. Of course, Andrew will provide you all necessary information about possible hub connections. 
    You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied. 

    Input

    The first line of the input contains two integer numbers: N - the number of hubs in the network (2 <= N <= 1000) and M - the number of possible hub connections (1 <= M <= 15000). All hubs are numbered from 1 to N. The following M lines contain information about possible connections - the numbers of two hubs, which can be connected and the cable length required to connect them. Length is a positive integer number that does not exceed 106. There will be no more than one way to connect two hubs. A hub cannot be connected to itself. There will always be at least one way to connect all hubs.

    Output

    Output first the maximum length of a single cable in your hub connection plan (the value you should minimize). Then output your plan: first output P - the number of cables used, then output P pairs of integer numbers - numbers of hubs connected by the corresponding cable. Separate numbers by spaces and/or line breaks.

    Sample Input

    4 6
    1 2 1
    1 3 1
    1 4 2
    2 3 1
    3 4 1
    2 4 1
    

    Sample Output

    1
    4
    1 2
    1 3
    2 3
    3 4
    

    Source

    Northeastern Europe 2001, Northern Subregion

    样例错误,,蛋疼。。。。。。。。。

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    
    using namespace std;
    
    const int N=1010;
    const int M=15010;
    
    struct Edge{
        int u,v;
        int cap;
    }edge[M<<1],res[N];
    
    int n,m,cnt,maxx,k;
    int father[N];
    
    void addedge(int cu,int cv,int cw){
        edge[cnt].u=cu;     edge[cnt].v=cv;     edge[cnt].cap=cw;
        cnt++;
    }
    
    void makeSet(){
        for(int i=1;i<=n;i++){
            father[i]=i;
        }
    }
    
    int findSet(int x){
        if(x!=father[x]){
            father[x]=findSet(father[x]);
        }
        return father[x];
    }
    
    int cmp(Edge a,Edge b){
        return a.cap<b.cap;
    }
    
    void Kruskal(){
        sort(edge,edge+cnt,cmp);
        for(int i=0;i<cnt;i++){
            int fx=findSet(edge[i].u);
            int fy=findSet(edge[i].v);
            if(fx!=fy){
                father[fy]=fx;
                if(maxx<edge[i].cap)
                    maxx=edge[i].cap;
                res[k].u=edge[i].u;
                res[k++].v=edge[i].v;
            }
        }
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        while(~scanf("%d%d",&n,&m)){
            cnt=0;
            k=0;
            maxx=0;
            makeSet();
            int u,v,w;
            while(m--){
                scanf("%d%d%d",&u,&v,&w);
                addedge(u,v,w);
            }
            Kruskal();
            printf("%d\n%d\n",maxx,k);
            for(int i=0;i<k;i++)
                printf("%d %d\n",res[i].u,res[i].v);
        }
        return 0;
    }
  • 相关阅读:
    Hive 导入、导出数据
    mysql 命令行参数说明
    mysql 查看表信息
    python之冒泡排序
    python之选择排序
    python之快速排序
    光荣之路测试开发面试linux考题之四:性能命令
    测试开发linux面试之三:后台进程之操作
    测试开发面试的Linux面试题总结之二:常用命令
    测试开发面试的Linux面试题总结之一:vim使用方法
  • 原文地址:https://www.cnblogs.com/jackge/p/3027182.html
Copyright © 2011-2022 走看看