zoukankan      html  css  js  c++  java
  • POJ Round and Round We Go

    Round and Round We Go

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 20000/10000K (Java/Other)
    Total Submission(s) : 1   Accepted Submission(s) : 1
    Problem Description
    A cyclic number is an integer n digits in length which, when multiplied by any integer from 1 to n, yields a"cycle"of the digits of the original number. That is, if you consider the number after the last digit to "wrap around"back to the first digit, the sequence of digits in both numbers will be the same, though they may start at different positions.For example, the number 142857 is cyclic, as illustrated by the following table: 142857 *1 = 142857 142857 *2 = 285714 142857 *3 = 428571 142857 *4 = 571428
    142857 *5 = 714285 142857 *6 = 857142
     
    Input
    Write a program which will determine whether or not numbers are cyclic. The input file is a list of integers from 2 to 60 digits in length. (Note that preceding zeros should not be removed, they are considered part of the number and count in determining n. Thus, "01"is a two-digit number, distinct from "1" which is a one-digit number.)
     
    Output
    For each input integer, write a line in the output indicating whether or not it is cyclic.
     
    Sample Input
    142857
    142856
    142858
    01
    0588235294117647
     
    Sample Output
    142857 is cyclic
    142856 is not cyclic
    142858 is not cyclic
    01 is not cyclic
    0588235294117647 is cyclic
     
    Source
    PKU
     
     
     
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    char str[100],s[100];
    int len;
    
    void Mul(int num,int a[],char s[]){
        int tmp=0,b[100];
        for(int i=0;i<len;i++)
            b[i]=a[i];
        for(int i=0;i<len;i++){
            tmp=b[i]*num+tmp;
            b[i]=tmp%10;
            tmp/=10;
            s[len-1-i]=b[i]+'0';
        }
        s[len]='\0';
        //printf("--------->  %s \n",s);
    }
    
    int isOk(char s1[],char s2[]){
        char s[200];
        strcpy(s,s1);
        strcat(s,s1);
        if(strstr(s,s2)!=NULL)      //这个strstr函数挺好用
            return 1;
        return 0;
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int a[100];
        while(~scanf("%s",str)){
            len=strlen(str);
            int i,j;
            for(i=len-1,j=0;i>=0;i--)
                a[j++]=str[i]-'0';
            for(i=2;i<=len;i++){
                Mul(i,a,s);
                if(!isOk(str,s))
                    break;
            }
            if(i>len)
                printf("%s is cyclic\n",str);
            else
                printf("%s is not cyclic\n",str);
        }
        return 0;
    }
  • 相关阅读:
    Linux内核RPC请求过程
    二分图
    Java实现 蓝桥杯 算法提高 合并石子
    Java实现 蓝桥杯 算法提高 合并石子
    Java实现 蓝桥杯 算法提高 摩尔斯电码
    Java实现 蓝桥杯 算法提高 摩尔斯电码
    Java实现 蓝桥杯 算法提高 文本加密
    Java实现 蓝桥杯 算法提高 文本加密
    Java蓝桥杯 算法提高 九宫格
    Java蓝桥杯 算法提高 九宫格
  • 原文地址:https://www.cnblogs.com/jackge/p/3035997.html
Copyright © 2011-2022 走看看