zoukankan      html  css  js  c++  java
  • POJ 3067 Japan (树状数组)

    Japan
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 16682   Accepted: 4467

    Description

    Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

    Input

    The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

    Output

    For each test case write one line on the standard output: 
    Test case (case number): (number of crossings)

    Sample Input

    1
    3 4 4
    1 4
    2 3
    3 2
    3 1

    Sample Output

    Test case 1: 5

    Source

    题意:东西两岸有N,M座城市 从北到南标号分别为1...N or M 在它们之间建铁路,每个站最多只能有两条铁路 求总的交点数

    思路:各连线按x降序(x相同,y降序)重排 再以y 建树状数组 注意有重边的情况

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    
    using namespace std;
    
    const int N=1010;
    
    struct node{
        int x,y;
    }tree[N*N];
    
    long long array[N];
    
    int cmp(node a,node b){
        if(a.x!=b.x)
            return a.x>b.x;
        return a.y>b.y;
    }
    
    int lowbit(int x){
        return x&(-x);
    }
    
    void add(int rt){
        while(rt<N){
            array[rt]+=1;
            rt+=lowbit(rt);
        }
    }
    
    long long sum(int rt){
        long long ans=0;
        while(rt>0){
            ans+=array[rt];
            rt-=lowbit(rt);
        }
        return ans;
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int t,n,m,k;
        int cases=0;
        scanf("%d",&t);
        while(t--){
            scanf("%d%d%d",&n,&m,&k);
            memset(array,0,sizeof(array));
            for(int i=0;i<k;i++)
                scanf("%d%d",&tree[i].x,&tree[i].y);
            sort(tree,tree+k,cmp);
            long long ans=0;
            for(int i=0;i<k;i++){
                ans+=sum(tree[i].y-1);
                add(tree[i].y);
            }
            printf("Test case %d: %I64d\n",++cases,ans);
        }
        return 0;
    }
  • 相关阅读:
    成功交付离岸项目
    利用CSP探测网站登陆状态
    Web NFC API
    HTML/W3C-WHATWG-Differences
    MIT教授将网页开发整合为完整独立的程式语言Ur/Web
    移动端前端开发调试
    从0到100——知乎架构变迁史
    C++之再续前缘(一)——C++基础(与C语言的差异)(上)
    又爱又恨系列之枚举enum
    数据结构之队列(三)——循环队列
  • 原文地址:https://www.cnblogs.com/jackge/p/3039504.html
Copyright © 2011-2022 走看看