zoukankan      html  css  js  c++  java
  • POJ 2192 Zipper

    Zipper
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 14127   Accepted: 4962

    Description

    Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order. 

    For example, consider forming "tcraete" from "cat" and "tree": 

    String A: cat 
    String B: tree 
    String C: tcraete 

    As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree": 

    String A: cat 
    String B: tree 
    String C: catrtee 

    Finally, notice that it is impossible to form "cttaree" from "cat" and "tree". 

    Input

    The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line. 

    For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive. 

    Output

    For each data set, print: 

    Data set n: yes 

    if the third string can be formed from the first two, or 

    Data set n: no 

    if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example. 

    Sample Input

    3
    cat tree tcraete
    cat tree catrtee
    cat tree cttaree
    

    Sample Output

    Data set 1: yes
    Data set 2: yes
    Data set 3: no
    

    Source

     
     
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    char str1[220],str2[220],str[520];
    int dp[220][220];   //dp[i][j]表示串1前i个字符和串2前j个字符能匹配的串3的最大字符数
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int t,cases=0;
        scanf("%d",&t);
        while(t--){
            scanf("%s%s%s",str1+1,str2+1,str+1);
            int len1=strlen(str1+1);
            int len2=strlen(str2+1);
            memset(dp,0,sizeof(dp));
            for(int i=0;i<=len1;i++)
                for(int j=0;j<=len2;j++){
                    if(i>0 && dp[i-1][j]==i-1+j && str1[i]==str[i+j])
                        dp[i][j]=i+j;
                    if(j>0 && dp[i][j-1]==i+j-1 && str2[j]==str[i+j])
                        dp[i][j]=i+j;
                }
            printf("Data set %d: %s\n",++cases,(dp[len1][len2]==len1+len2)?"yes":"no");
        }
        return 0;
    }
  • 相关阅读:
    Arrays.fill方法的陷阱
    彻底弄懂最短路径问题
    《c++primer》疑惑记录
    C++ 隐含的this 指针
    c++ 内存分配
    抽象 与 封装 区别
    iconv 文件编码转换
    python中文分词工具——结巴分词
    词形变换和词干提取工具(英文)
    python 绘图工具 matplotlib 入门
  • 原文地址:https://www.cnblogs.com/jackge/p/3101006.html
Copyright © 2011-2022 走看看