zoukankan      html  css  js  c++  java
  • ZOJ Problem Set

    ZOJ Problem Set - 1649
      Rescue

    Time Limit: 2 Seconds                                    Memory Limit:65536 KB                            

    Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison   is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and   GUARDs in the prison.

    Angel's friends want to save Angel. Their task is: approach Angel. We assume   that "approach Angel" is to get to the position where Angel stays.   When there's a guard in the grid, we must kill him (or her?) to move into the   grid. We assume that we moving up, down, right, left takes us 1 unit time, and   killing a guard takes 1 unit time, too. And we are strong enough to kill all   the guards.

    You have to calculate the minimal time to approach Angel. (We can move only   UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)


    Input

    First line contains two integers stand for N and M.

    Then N lines follows, every line has M characters. "." stands for   road, "a" stands for Angel, and "r" stands for each of Angel's   friend.

    Process to the end of the file.


    Output

    For each test case, your program should output a single integer, standing for   the minimal time needed. If such a number does no exist, you should output a   line containing "Poor ANGEL has to stay in the prison all his life." 


    Sample Input

    7 8
      #.#####.
      #.a#..r.
      #..#x...
      ..#..#.#
      #...##..
      .#......
      ........


    Sample Output

    13

    广度优先搜索题:

    #include<iostream>
    #include<stdio.h>
    #include<string.h>
    #include<queue>
    #define MAX 200
    #define INF 100000
    using namespace std;
    struct Point{
    	int r,c;
    	int time;
    };
    char map[MAX][MAX];
    int mintime[MAX][MAX];
    int dir[4][2]={{0,-1},{-1,0},{0,1},{1,0}};
    int m,n;
    int dr,dc;
    int BFS(int r,int c)
    {
    	queue<Point> q;
    	int time=INF;
    	Point p1;
    	p1.r=r;
    	p1.c=c;
    	p1.time=0;
    	mintime[r][c]=0;
    	q.push(p1);
    	while(!q.empty())
    	{
    		Point tp=q.front();
    		q.pop();
    		for(int i=0;i<4;i++)
    		{
    			///cout<<"mark #1"<<endl;
    			int tr=tp.r+dir[i][0];
    			int tc=tp.c+dir[i][1];
    		//	cout<<"tr: "<<tr<<" tc: "<<tc<<endl;
    			if(tr>=0&&tr<m&&tc>=0&&tc<n&&map[tr][tc]!='#')
    			{
    			//	cout<<"mark #2"<<endl;
    				int tt=tp.time;
    				tt++;
    				if(map[tr][tc]=='x')
    				    tt++;
    				Point tp2;
    				tp2.r=tr;tp2.c=tc;tp2.time=tt;
    			//	cout<<"tt: "<<tt<<endl;
    				//cout<<"mintime[tr][tc]: "<<mintime[tr][tc]<<endl;
    				if(tt<mintime[tr][tc])
    				{
    				    mintime[tr][tc]=tt;
    					q.push(tp2);
    				}
    			//	cout<<"mark #3"<<endl;
    			}
    		}
    	}
    	return mintime[dr][dc];
    }
    int main()
    {
    	while(cin>>m>>n)
    	{
    		int sr,sc;
    		for(int i=0;i<m;i++)
    		{
    			for(int j=0;j<n;j++)
    			{
    				mintime[i][j]=INF;
    				cin>>map[i][j];
    				char t=map[i][j];
    				if(t=='r')
    				{
    					sr=i;sc=j;
    				}
    				if(t=='a')
    				{
    					dr=i;dc=j;
    				}
    			}
    		}
    		int result=BFS(sr,sc);
    		if(result!=INF)
    		cout<<result<<endl;
    		else cout<<"Poor ANGEL has to stay in the prison all his life."<<endl;
    	/*	for(int i=0;i<m;i++)
    		{
    			for(int j=0;j<n;j++)
    			{
    				cout<<mintime[i][j]<<'	';
    				//cout<<map[i][j]<<' ';
    			}
    			cout<<endl;
    		}*/
    	}
    }
    


     

  • 相关阅读:
    定力
    cordova build android 环境的坑
    我和数据差个“axios" -- axios的原理解析
    Promise的原理探究及手写Promise
    vue长列表优化
    koa-中间件使用
    vue组件库自动生成文档-vue-styleguidist(二)
    vue组件库自动生成文档-vue-styleguidist(一)
    vue组件库自动生成文档-生成方式对比(1)
    我的目录
  • 原文地址:https://www.cnblogs.com/jackwuyongxing/p/3366491.html
Copyright © 2011-2022 走看看