zoukankan      html  css  js  c++  java
  • POJ_2255_Tree Recovery

    Tree Recovery
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 12342   Accepted: 7712

    Description

    Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 
    This is an example of one of her creations: 

    D
    /
    /
    B E
    /
    /
    A C G
    /
    /
    F

    To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG. 
    She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 

    Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 
    However, doing the reconstruction by hand, soon turned out to be tedious. 
    So now she asks you to write a program that does the job for her! 

    Input

    The input will contain one or more test cases. 
    Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.) 
    Input is terminated by end of file. 

    Output

    For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

    Sample Input

    DBACEGF ABCDEFG
    BCAD CBAD
    

    Sample Output

    ACBFGED
    CDAB3
    题解:在前序中取根节点,在中序中找到该节点,其左边为该根节点左子树,右边为右子树
    代码:
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    using namespace std;
    char fro[27],mid[27];
    void beh(int fs,int fe,int ms,int me)
    {
        if(fs==fe)
        {
            cout<<fro[fs];
            return;
        }
        if(fs>fe||ms>me)
            return;
        char root=fro[fs];
        int i;
        for(i=ms;i<me;i++)
            if(root==mid[i])
                break;
        int len=i-ms;
        beh(fs+1,fs+len,ms,i-1);
        beh(fs+len+1,fe,i+1,me);
        cout<<root;
    }
    int main()
    {
        while(scanf("%s%s",fro,mid)!=EOF)
        {
            int len=strlen(fro);
            beh(0,len-1,0,len-1);
            cout<<endl;
        }
        return 0;
    }
  • 相关阅读:
    【HDOJ】1811 Rank of Tetris
    【HDOJ】1518 Square
    日期类 Date
    RunTime
    System 系统类
    StringBuffer
    获取联系人列表的时候contact_id出现null的值
    String类
    object类
    eclipse使用的步骤
  • 原文地址:https://www.cnblogs.com/jasonlixuetao/p/4534314.html
Copyright © 2011-2022 走看看