zoukankan      html  css  js  c++  java
  • HDU_1711_初识KMP算法

    Number Sequence

    Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 22568    Accepted Submission(s): 9639


    Problem Description
    Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
     
    Input
    The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
     
    Output
    For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
     
    Sample Input
    2
    13 5
    1 2 1 2 3 1 2 3 1 3 2 1 2
    1 2 3 1 3
    13 5
    1 2 1 2 3 1 2 3 1 3 2 1 2
    1 2 3 2 1
     
    Sample Output
    6
    -1
     
     
    long long ago:KMP算法还需多理解。
     
    2017.2.27 15:09 第一次复习KMP,看着代码什么也想不起来,然后看了两篇博文。
        写写这次复习的体会,求next数组,我的体会是求模式串str和自己本身的对称性,也如第一篇博文中讲的那样,next[i]即为
      模式串的子串str[1--i]的所有前缀和所有后缀的最长的共有元素的长度(此处前缀后缀的定义可以在博文1中看到)。
        得到next数组后,即可进行KMP算法,匹配时,若在当前位置j匹配失败,那么就将模式串str右移next[j]位,而不是每次右
      移一位这就是。
      多写博客,方便复习。
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<stdlib.h>
    #include<algorithm>
    #include<cmath>
    using namespace std;
    
    int n,m;
    int N[1000005],M[10005],Pi[10005];
    
    void preFix()   //构造next数组(寻找模式串的对称性)
    {
        memset(Pi,0,sizeof(Pi));
        int k=0;
        for(int q=2;q<=m;q++)
        {
            while(k>0&&M[k+1]!=M[q]) //不相等,则向前递推,对称性减小
                k=Pi[k];
            if(M[k+1]==M[q])   //若相等,对称性继续扩大
                k++;
            Pi[q]=k;
        }
    }
    
    int KMP()
    {
        preFix();
        int q=0;
        for(int i=1;i<=n;i++)
        {
            while(q>0&&M[q+1]!=N[i])
                q=Pi[q];
            if(M[q+1]==N[i])
                q++;
            if(q==m)
                return i-m+1;
        }
        return -1;
    }
    int main() { int t; scanf("%d",&t); while(t--) { scanf("%d%d",&n,&m); for(int i=1;i<=n;i++) scanf("%d",&N[i]); for(int j=1;j<=m;j++) scanf("%d",&M[j]); int ans=KMP(); printf("%d ",ans); } return 0; }
     
     
  • 相关阅读:
    c# – 通过反射获取命名空间中的所有类型
    宝塔任务计划通道设置
    DRF项目框架基础设计
    Redis-数据特征和应用场景
    Redis-持久化详解
    Dockerfile文件详解
    ntp同步阿里服务器时间(centos)
    NUC8/11更新EC Firmware
    ambarella H2 kernel调试记录
    MobaXterm 执行make menuconfig不能删除字符
  • 原文地址:https://www.cnblogs.com/jasonlixuetao/p/5905636.html
Copyright © 2011-2022 走看看