zoukankan      html  css  js  c++  java
  • uva440 Eeny Meeny Moo约瑟夫环

     Eeny Meeny Moo 

    Surely you have made the experience that when too many people use the Internet simultaneously, the net becomes very, very slow.

    To put an end to this problem, the University of Ulm has developed a contingency scheme for times of peak load to cut off net access for some cities of the country in a systematic, totally fair manner. Germany's cities were enumerated randomly from 1 to n. Freiburg was number 1, Ulm was number 2, Karlsruhe was number 3, and so on in a purely random order.

    Then a number m would be picked at random, and Internet access would first be cut off in city 1 (clearly the fairest starting point) and then in every mth city after that, wrapping around to 1 after n, and ignoring cities already cut off. For example, if n=17 and m=5, net access would be cut off to the cities in the order [1,6,11,16,5,12,2,9,17,10,4,15,14,3,8,13,7]. The problem is that it is clearly fairest to cut off Ulm last (after all, this is where the best programmers come from), so for a given n, the random number m needs to be carefully chosen so that city 2 is the last city selected.

    Your job is to write a program that will read in a number of cities n and then determine the smallest integer m that will ensure that Ulm can surf the net while the rest of the country is cut off.

    Input Specification

    The input file will contain one or more lines, each line containing one integer n with tex2html_wrap_inline43 , representing the number of cities in the country.

    Input is terminated by a value of zero (0) for n.

    Output Specification

    For each line of the input, print one line containing the integer m fulfilling the requirement specified above.

    Sample Input

    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    0

    Sample Output

    2
    5
    2
    4
    3
    11
    2
    3
    8
    16

    著名的约瑟夫环,看了好久的资料。。。

    用正常的做法是会超时的。。。略坑。。。

    优化过的代码异常的短。

    代码:

    #include<iostream>
    using namespace std;
    
    int main()
    {
    	int n;
    	while (cin >> n && n)
    	{
    		int cross;
    		for (cross = 1; ; cross++)
    		{
    			int cur = 1;
    			for (int i = 2; i <= n - 1; i++)
    				cur = (cur + cross - 1) % i + 1;
    			if (cur == 1)
    				break;
    		}
    		cout << cross << endl;
    	}
    	return 0;
    }



  • 相关阅读:
    java获取src下包的文件的路径
    Java获取日期属于当年第几周
    DIV的内容自动换行
    js验证身份证格式
    处理 WebService 中的 Map 对象
    Oracle使用row_number()函数查询时增加序号列
    SpingMVC实现集合参数(Could not instantiate bean class [java.util.List])
    利用JS实现在li中添加或删除class属性
    栈的应用之中缀表达式转后缀表达式
    栈的应用之判断括号匹配
  • 原文地址:https://www.cnblogs.com/java20130723/p/3212171.html
Copyright © 2011-2022 走看看