zoukankan      html  css  js  c++  java
  • POJ 2704(Pascal's Travels裸dp)

    Language:
    Pascal's Travels
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 4821   Accepted: 2139

    Description

    An n x n game board is populated with integers, one nonnegative integer per square. The goal is to travel along any legitimate path from the upper left corner to the lower right corner of the board. The integer in any one square dictates how large a step away from that location must be. If the step size would advance travel off the game board, then a step in that particular direction is forbidden. All steps must be either to the right or toward the bottom. Note that a 0 is a dead end which prevents any further progress. 

    Consider the 4 x 4 board shown in Figure 1, where the solid circle identifies the start position and the dashed circle identifies the target. Figure 2 shows the three paths from the start to the target, with the irrelevant numbers in each removed. 

    Input

    The input contains data for one to thirty boards, followed by a final line containing only the integer -1. The data for a board starts with a line containing a single positive integer n, 4 <= n <= 34, which is the number of rows in this board. This is followed by n rows of data. Each row contains n single digits, 0-9, with no spaces between them.

    Output

    The output consists of one line for each board, containing a single integer, which is the number of paths from the upper left corner to the lower right corner. There will be fewer than 2 63 paths for any board. 

    Sample Input

    4
    2331
    1213
    1231
    3110
    4
    3332
    1213
    1232
    2120
    5
    11101
    01111
    11111
    11101
    11101
    -1
    

    Sample Output

    3
    0
    7

    Hint

    Brute force methods examining every path will likely exceed the allotted time limit. 64-bit integer values are available as long values in Java or long long values using the contest's C/C++ compilers.

    Source

    就是dp……

    一开始忘打‘\n’ wa了……

    #include<cstdio>
    #include<cstdlib>
    #include<algorithm>
    #include<cstring>
    using namespace std;
    #define MAXN (34+1)
    int a[MAXN][MAXN],n;
    long long f[MAXN][MAXN];
    int main()
    {
    	while (scanf("%d",&n)&&n+1)
    	{
    		for (int i=1;i<=n;i++)
    		{
    			char s[MAXN];
    			scanf("%s",s+1);
    			for (int j=1;j<=n;j++) a[i][j]=s[j]-'0';			
    		}
    		memset(f,0,sizeof(f));f[1][1]=1;
    		for (int i=1;i<=n;i++)
    			for (int j=1;j<=n;j++)
    				if (a[i][j])
    				{
    					if (i+a[i][j]<=n) f[i+a[i][j]][j]+=f[i][j];
    					if (j+a[i][j]<=n) f[i][j+a[i][j]]+=f[i][j];
    				}
    		printf("%lld\n",f[n][n]);
    	}
    	return 0;
    }



  • 相关阅读:
    DateTimePicker控件在WinXP下的BUG
    SmartAssembly .net混淆后,无法找到部分类型
    RPC_E_SERVERFAULT excel com操作错误
    System.Reflection.ReflectionTypeLoadException
    login SMTP send mail error : Unable to read data from the transport connection: net_io_connectionclosed
    静态类无法实现接口
    Combobox出现System.Data.DataRowView的原因
    .net 4.0 : Missing compiler required member 'Microsoft.CSharp.RuntimeBinder.Binder.****'
    EOS 主节点同步
    使用tcpdump抓取EOS帐户创建与交易数据
  • 原文地址:https://www.cnblogs.com/javawebsoa/p/2981428.html
Copyright © 2011-2022 走看看