zoukankan      html  css  js  c++  java
  • HDU1397:Goldbach's Conjecture

    Problem Description
    Goldbach's Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2.  
    This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

    A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.
     
    Input
    An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 2^15. The end of the input is indicated by a number 0.
     
    Output
    Each output line should contain an integer number. No other characters should appear in the output.
     
    Sample Input
    6 10 12 0
     
    Sample Output
    1 2 1
     
    #include <stdio.h>
    #include <string.h>
    int prime[1000000];
    
    void sushu(void)
    {
        memset(prime,1,sizeof(prime));
        int i,j;
        for(i = 2; i<=500000; i++)
        {
            if(prime[i])
            {
                for(j = i+i; j<1000000; j+=i)
                {
                    prime[j] = 0;
                }
            }
        }
    }
    
    int main()
    {
        int n;
        sushu();
        while(~scanf("%d",&n),n)
        {
            int i,cnt = 0;
            for(i = 2;i<=n/2;i++)
            {
                if(prime[i] && prime[n-i])
                cnt++;
            }
            printf("%d\n",cnt);
        }
        return 0;
    }
    



  • 相关阅读:
    【angularJS】启动(bootstrap)机制
    【angularJS】定义模块angular.module
    【angularJS】简介
    .NET AutoMapper学习记录
    WebAPI学习
    【MongoDB】在C#中使用
    RabbitMQ介绍及windows下安装使用
    【MongoDB】初识
    php命名空间(nameSpace)的使用详解
    魔术方法
  • 原文地址:https://www.cnblogs.com/javawebsoa/p/2995445.html
Copyright © 2011-2022 走看看