zoukankan      html  css  js  c++  java
  • HDU1061:Rightmost Digit

    Problem Description
    Given a positive integer N, you should output the most right digit of N^N.
     
    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case contains a single positive integer N(1<=N<=1,000,000,000).
     
    Output
    For each test case, you should output the rightmost digit of N^N.
     
    Sample Input
    2 3 4
     
    Sample Output
    7 6
    Hint
    In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
     


     

    //这道题与HDU1097题基本就是一样的

    只需要稍微改一下就可以了

    #include <stdio.h>
    #include<string.h>
    int main()
    {
        int a,b,n,t;
        scanf("%d",&t);
        while(t--)
        {
            scanf("%d",&a);
            n=a%10;
            b = a;
            if(b==0)
                printf("1\n");
            else
            {
                switch(n)
                {
                case 0:
                case 1:
                case 6:
                    break;
                case 2:
                    n=b%4;
                    switch(n)
                    {
                    case 1:
                        n=2;
                        break;
                    case 2:
                        n=4;
                        break;
                    case 3:
                        n=8;
                        break;
                    case 0:
                        n=6;
                        break;
                    }
                    break;
                case 3:
                    n=b%4;
                    switch(n)
                    {
                    case 1:
                        n=3;
                        break;
                    case 2:
                        n=9;
                        break;
                    case 3:
                        n=7;
                        break;
                    case 0:
                        n=1;
                        break;
                    }
                    break;
                case 4:
                    n=b%2;
                    switch(n)
                    {
                    case 1:
                        n=4;
                        break;
                    case 0:
                        n=6;
                        break;
                    }
                    break;
                case 7:
                    n=b%4;
                    switch(n)
                    {
                    case 1:
                        n=7;
                        break;
                    case 2:
                        n=9;
                        break;
                    case 3:
                        n=3;
                        break;
                    case 0:
                        n=1;
                        break;
                    }
                    break;
                case 8:
                    n=b%4;
                    switch(n)
                    {
                    case 1:
                        n=8;
                        break;
                    case 2:
                        n=4;
                        break;
                    case 3:
                        n=2;
                        break;
                    case 0:
                        n=6;
                        break;
                    }
                    break;
                case 9:
                    n=b%2;
                    switch(n)
                    {
                    case 1:
                        n=9;
                        break;
                    case 0:
                        n=1;
                        break;
                    }
                    break;
                }
            }
            printf("%d\n",n);
        }
        return 0;
    }
    
    


     

  • 相关阅读:
    Codeforces Round 718C Sasha and Array (矩阵线段树)
    Ural Timus 1009 K-based Numbers (dp+矩阵快速幂+快速乘)
    CPE常用指令
    Error opening terminal:xterm解决方法
    编译MT7620n NFS文件系统
    ubuntu中把dash链接变成bash
    USB相关
    HI3515海思开发板移植3G模块笔记
    openwrt的一些琐事
    snprintf拷贝字符串
  • 原文地址:https://www.cnblogs.com/javawebsoa/p/2999598.html
Copyright © 2011-2022 走看看