zoukankan      html  css  js  c++  java
  • HDU1056:HangOver

    Problem Description
    How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.

     

    The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

    For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.
     
    Sample Input
    1.00 3.71 0.04 5.19 0.00
     
    Sample Output
    3 card(s) 61 card(s) 1 card(s) 273 card(s)
     


     

    #include <stdio.h>
    
    int main()
    {
        double a;
        while(~scanf("%lf",&a),a)
        {
            double b = 0,i;
            for(i = 1;b<a;i++)
            {
                b+=1/(i+1);
            }
            printf("%.0lf card(s)\n",i-1);
        }
        return 0;
    }
    


     

  • 相关阅读:
    禁止WebBrowser控件弹出对话框
    c#禁止Webbrowser控件的弹出脚本错误对话框
    Spread 常用属性
    没有ID的验证码图片,调用方法将图片保存到本地
    C#网页表单自动填写实现原理
    LInqWhere
    加密与解密数据库中数据
    DataAdapter批量处理数据
    OperateXMLDateSet
    jquery json
  • 原文地址:https://www.cnblogs.com/javawebsoa/p/2999606.html
Copyright © 2011-2022 走看看