zoukankan      html  css  js  c++  java
  • HDUOJ Let the Balloon Rise 1004

    
    /*
    Let the Balloon Rise
    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 89272    Accepted Submission(s): 33796
    Problem Description
    Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.
    This year, they decide to leave this lovely job to you.
    Input
    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.
    A test case with N = 0 terminates the input and this test case is not to be processed.
    Output
    For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
    Sample Input
    5
    green
    red
    blue
    red
    red
    3
    pink
    orange
    pink
    0
    Sample Output
    red
    pink
    Author
    WU, Jiazhi
    Source
    ZJCPC2004 
    RecommendGShining   |   We have carefully selected several similar problems for you:  1001 1008 1005 1003 1000
     */
     //字符组灵活运用
    #include<stdio.h>
    #include<stdlib.h>
    #include<string.h>
    int main()
    {
     int n;
     char s[1001][16];
     int b[1001];
     while(scanf("%d",&n),n)
     {
      int k;
      memset(b,0,sizeof(b));
      for(int i=0;i<n;i++)
      {
       scanf("%s",s[i]);
       for(int j=0;j<=i;j++)
       {
        if(strcmp(s[i],s[j])==0) b[j]++;
       }
         }
         k=0;
         for(int i=1;i<n;i++)
         {
          if(b[k]<b[i]) k=i;
         }
         printf("%s ",s[k]);
     }
     return 0;
    }
  • 相关阅读:
    Oracle -- Create Tablespace
    EntityFramework-DBFirst-重新生成后写的验证消失(解决办法)
    UILocalNotification本地通知
    属性观察者willSet与didSet
    常用后台frame框架
    Windows常用CMD命令
    常用的格式符与转义字符
    Windows操作系统常用快捷键
    Mac操作系统常用快捷键
    srp render queue 失效
  • 原文地址:https://www.cnblogs.com/jhcelue/p/6979701.html
Copyright © 2011-2022 走看看