zoukankan      html  css  js  c++  java
  • HDOJ(HDU) 1977 Consecutive sum II(推导、、)

    Problem Description
    Consecutive sum come again. Are you ready? Go ~~
    1 = 0 + 1
    2+3+4 = 1 + 8
    5+6+7+8+9 = 8 + 27

    You can see the consecutive sum can be representing like that. The nth line will have 2*n+1 consecutive numbers on the left, the first number on the right equal with the second number in last line, and the sum of left numbers equal with two number’s sum on the right.
    Your task is that tell me the right numbers in the nth line.

    Input
    The first integer is T, and T lines will follow.
    Each line will contain an integer N (0 <= N <= 2100000).

    Output
    For each case, output the right numbers in the Nth line.
    All answer in the range of signed 64-bits integer.

    Sample Input
    3
    0
    1
    2

    Sample Output
    0 1
    1 8
    8 27

    看到有非常多人的这个题目是找规律做的。我開始没注意规律了,
    就打表做了。

    。。
    如今给出2种能AC的方法:

    第一种:打表:

    import java.util.Scanner;
    
    public class Main{
        static long[] db1 = new long[2100005];
        public static void main(String[] args) {
            dabiao();
            //System.out.println("aa");
            Scanner sc = new Scanner(System.in);
            int t = sc.nextInt();
            while(t-->0){
                int n = sc.nextInt();
                System.out.println(db1[n]+" "+db1[n+1]);
            }
        }
        private static void dabiao() {
            db1[0] = 0;
            db1[1] = 1;
            db1[2] = 8;
            db1[3] = 27;
            long k=9;
            long num =7;
            Scanner sc = new Scanner(System.in);
            for(int i=4;i<=2100001;i++){
                db1[i] =(k+num/2+1)*num-db1[i-1];
    //          System.out.println(k);
    //          System.out.println(num/2+1);
    //          
    //          System.out.println(i);
    //          System.out.println(db1[i]);
    //          System.out.println((k+num/2+1)*num);
    //          int m = sc.nextInt();
                k=k+num;
                num+=2;
    
            }
        }
    }
    

    另外一种:找规律:

    import java.util.Scanner;
    
    public class Main {
    
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            int t  =sc.nextInt();
    
            while(t-->0){
                long n =sc.nextLong();
                System.out.println(n*n*n+" "+(n+1)*(n+1)*(n+1));
            }
        }
    }
    
  • 相关阅读:
    textarea宽度、高度自动适应处理方法
    Table嵌套去掉子table的外边框
    发现原来自己挺能给自己找理由开脱的
    Life is not the amount of breath you take.
    在遍历ResultSet的循环中再执行SQL会发生什么(前提:同一个Statement)
    按月查询数据
    Oracle SQL 判断某表是否存在
    在Python程序中执行linux命令
    在Oracle中十分钟内创建一张千万级别的表
    Redis Sentinel结构 及相关文档
  • 原文地址:https://www.cnblogs.com/jhcelue/p/7279631.html
Copyright © 2011-2022 走看看