zoukankan      html  css  js  c++  java
  • HDU2034 人见人爱A-B

    参加过上个月月赛的同学一定还记得其中的一个最简单的题目,就是{A}+{B},那个题目求的是两个集合的并集,今天我们这个A-B求的是两个集合的差,就是做集合的减法运算。(当然,大家都知道集合的定义,就是同一个集合中不会有两个相同的元素,这里还是提醒大家一下)
    呵呵,很简单吧?

    Input

    每组输入数据占1行,每行数据的开始是2个整数n(0<=n<=100)和m(0<=m<=100),分别表示集合A和集合B的元素个数,然后紧跟着n+m个元素,前面n个元素属于集合A,其余的属于集合B. 每个元素为不超出int范围的整数,元素之间有一个空格隔开.
    如果n=0并且m=0表示输入的结束,不做处理。

    Output

    针对每组数据输出一行数据,表示A-B的结果,如果结果为空集合,则输出“NULL”,否则从小到大输出结果,为了简化问题,每个元素后面跟一个空格.

    Sample Input
    3 3 1 2 3 1 4 7
    3 7 2 5 8 2 3 4 5 6 7 8
    0 0
    Sample Output
    2 3
    NULL

    做这题体会到了C++容器的set类实在太好用了,不过貌似用C语言中归并排序也能写出来。不过目前我还没理解,太菜了。。。戳这儿~

    代码一(C++)(AC):

    #include <iostream>
    #include <set>
    
    using namespace std;
    
    int main()
    {
        int n, m, val;
        set<int> result;
    
        while (cin >> n >> m) {
            if (n == 0 && m == 0)
                break;
    
            result.clear();
    
            // n个元素放进集合中
            for (int i = 1; i <= n; i++) {
                cin >> val;
                result.insert(val);
            }
    
            // m个元素,如果在集合中,则删除该元素
            for (int i = 1; i <= m; i++) {
                cin >> val;
    
                if (result.find(val) != result.end()) {
                    result.erase(val);
                }
            }
    
            // 打印输出结果
            if (result.size() == 0)
                cout << "NULL" << endl;
            else {
                for (set<int>::iterator it = result.begin(); it != result.end(); it++)
                    cout << *it << " ";
                cout << endl;
            }
        }
    
        return 0;
    }
    天晴了,起飞吧
  • 相关阅读:
    Leetcode: Longest Increasing Subsequence
    Leetcode: Bulls and Cows
    Leetcode: Serialize and Deserialize Binary Tree
    undefined reference to symbol '_ZNK11GenICam_3_016GenericException17GetSourceFileNameEv'
    ranlib 作用
    live555运行时报错:StreamParser internal error ( 86451 + 64000 > 150000)
    qt 免注册下载
    modsign: could't get uefi db list
    ubuntu安装 opencv-3.4.3
    xl2tpd[26104]: Maximum retries exceeded for tunnel 33925. Closing
  • 原文地址:https://www.cnblogs.com/jianqiao123/p/11238352.html
Copyright © 2011-2022 走看看